Краткое руководство по сетевому администрированию [Руководство сетевого администратора AutoCAD: ]

Подготовка к развертыванию
Краткое руководство по сетевому администрированию

Сетевое развертывание этой программы должно быть тщательно спланировано и выполнено аккуратно. В данном разделе приводится краткое описание процедур подготовки развертывания, настройки сервера лицензий, настройки и распространения программы.

При отсутствии опыта администрирования и развертывания сети перед развертыванием и настройкой программы в сети следует внимательно прочитать Руководство сетевого администратора.

Темы в этом разделе

  • Подготовка к развертыванию
  • Настройка сервера лицензий
  • Настройка и распространение программы
Отправьте ваши комментарии по поводу этой страницы


Подготовка к развертыванию [Руководство сетевого администратора AutoCAD: ]

Краткое руководство по сетевому администрированию
Краткое руководство по сетевому администрированию
Как выбрать тип установки
Подготовка к развертыванию

Для подготовки к развертыванию необходимо выбрать тип установки и модель сервера лицензий.

Темы в этом разделе

  • Как выбрать тип установки
  • Выбор конфигурации сервера лицензий


Как выбрать тип установки [Руководство сетевого администратора AutoCAD: ]

Подготовка к развертыванию
Подготовка к развертыванию
Выбор конфигурации сервера лицензий
Как выбрать тип установки

Вариант установки задается при настройке параметров развертывания. В мастере развертывания необходимо выбрать один из следующих вариантов установки:

  • С сетевой лицензией. При этом программа устанавливается на рабочие станции вместе с файлами и параметрами реестра, которые обеспечивают взаимодействие с Диспетчером сетевых лицензий Network License Manager. В Диспетчере сетевых лицензий можно разрешить доступ к лицензиям. Для работы программы после ее сетевой установки на рабочую станцию не требуется индивидуальной активации. Лицензии на программу распределяются, по крайней мере, с одного сервера.
  • Автономная установка. Выберите этот тип установки для автономной установки (один серийный номер для одного пользователя) или автономной установки для нескольких пользователей (один серийный номер для нескольких установок). Диспетчер сетевых лицензий в данном случае не используется. В случае автономной установки производится установка, регистрация и активация программы на каждой рабочей станции. После первой активации с помощью серийного номера для автономной установки на нескольких пользователей активация выполняется автоматически для всех рабочих станций в зависимости от развертывания, если эти рабочие станции подключены к Интернету. Подробнее о возможностях этого варианта установки см. Настройка и распространение программы.


Выбор конфигурации сервера лицензий [Руководство сетевого администратора AutoCAD: ]

Как выбрать тип установки
Подготовка к развертыванию
Настройка сервера лицензий
Выбор конфигурации сервера лицензий

Если выбран вариант сетевой установки продукта, следует выбрать модель сервера лицензий для распространения лицензий. (В случае развертывания автономной установки на одного или нескольких пользователей модель сервера лицензий не используется.)

При сетевой установке доступны следующие модели серверов лицензий:

  • Конфигурация с одним сервером лицензий. Диспетчер сетевых лицензий устанавливается на одном сервере, на котором и осуществляется вся деятельность по управлению лицензиями. Все лицензии, доступные на сервере, представлены в едином файле лицензий.
  • Конфигурация с несколькими серверами лицензий. Для управления лицензиями используется несколько серверов. Для каждого сервера необходим собственный уникальный файл лицензий. Для создания распределенного сервера лицензий необходимо запустить Network License Manager на каждом из серверов, входящих в распределенный серверный пул.
  • Конфигурация с резервными серверами лицензий. Для работы с единственным файлом лицензий используются три сервера. Один из них является основным, а два других — резервными, используемыми при сбое основного сервера. В этой конфигурации выдача лицензий не прекращается, если функционируют хотя бы два из этих трех серверов. Файл лицензий одинаков на всех трех серверах. На каждом из серверов необходимо установить Network License Manager.

Каждая из конфигураций серверов лицензий подробно описана в Руководстве по сетевому лицензированию. Настоятельно рекомендуется ознакомиться с этим руководством перед развертыванием программы. Руководство по сетевому лицензированию можно найти в справочной системе и на вкладке "Документация" обозревателя диска.


Настройка сервера лицензий [Руководство сетевого администратора AutoCAD: ]

Выбор конфигурации сервера лицензий
Краткое руководство по сетевому администрированию
Установка Network License Manager
Настройка сервера лицензий

Если планируется работа пользователей с сетевыми лицензиями на программный продукт, следует воспользоваться Диспетчером сетевых лицензий и программой активации сетевой лицензии.

Диспетчер сетевых лицензий Network License Manager служит для настройки серверов лицензий и управления ими. Программа активации сетевой лицензии позволяет получать и регистрировать лицензии через Интернет.

Темы в этом разделе

  • Установка Network License Manager
  • Установка и использование программы активации сетевой лицензии
  • Настройка сервера лицензий


Установка Network License Manager [Руководство сетевого администратора AutoCAD: ]

Настройка сервера лицензий
Настройка сервера лицензий
Установка и использование программы активации сетевой лицензии
Установка Network License Manager

Network License Manager (Диспетчер сетевых лицензий) служит для настройки серверов лицензий и управления ими.

Для установки Network License Manager

  1. В обозревателе диска откройте вкладку "Установка".
  2. На вкладке "Установка" выберите "Сетевое развертывание".
  3. В группе "Установка компонентов лицензирования" нажмите ссылку "Network License Manager".
  4. На странице "Autodesk Network License Manager Setup" (Настройка Autodesk Network License Manager) нажмите "Next" (Далее).
  5. На странице "License Agreement" (Лицензионный договор) прочтите лицензионный договор, установите флажок "I Accept" (Принимаю) и нажмите "Далее".
    ЗамечаниеВ случае несогласия с условиями договора нужно нажать кнопку "Cancel" (Отмена) для отмены установки.
  6. На странице "Destination Folder" (Папка для установки) примите заданную по умолчанию папку ((C:\Program Files\Autodesk Network License Manager\) или нажмите кнопку "Browse" (Обзор) для указания другой папки для установки. Если папка с указанным пользователем именем не существует, Мастер создает ее. Нажмите "Next" (Далее).
    ПредупреждениеNetwork License Manager не может быть установлен на сетевом диске. Папка для установки Network License Manager должна быть локальной. Необходимо явно указывать букву имени диска; формат универсального именования (UNC) здесь не подходит.
  7. На странице "Ready to Install the Application" (Начало установки) нажмите кнопку "Next" (Далее), чтобы перейти к копированию файлов на диск.
  8. Нажмите "Finish" (Готово).


Установка и использование программы активации сетевой лицензии [Руководство сетевого администратора AutoCAD: ]

Установка Network License Manager
Настройка сервера лицензий
Настройка сервера лицензий
Установка и использование программы активации сетевой лицензии

Программа активации сетевой лицензии служит для получения лицензий через Интернет. Тем самым экономятся время и силы, затрачиваемые на подготовку программы к работе в сетевой среде. Кроме того, утилита позволяет зарегистрировать продукт, получить поддержку по электронной почте (в случаях, когда не удается получить лицензию через Интернет), а также автоматически сохранять и переносить файлы с лицензиями.

Для установки программы активации сетевой лицензии

  1. В обозревателе диска откройте вкладку "Установка".
  2. На вкладке "Установка" выберите "Сетевое развертывание".
  3. В группе "Установка компонентов лицензирования" нажмите ссылку "Программа активации сетевой лицензии".
  4. На странице "Установка программы активации сетевой лицензии AutoCAD 2007" нажмите кнопку "Далее".
  5. На странице "Лицензионный договор" прочтите лицензионный договор, установите флажок "I accept" (Принимаю) и нажмите "Далее".
    ЗамечаниеВ случае несогласия с условиями договора нужно нажать кнопку "Cancel" (Отмена) для отмены установки.
  6. На странице "Destination Folder" (Папка для установки) примите заданную по умолчанию папку (C:\Program Files\Autodesk Network License Manager\Network License Activation Utility\ ) или нажать кнопку "Browse" (Обзор) для указания другой папки для установки. Если папка с указанным пользователем именем не существует, Мастер создает ее. Нажмите "Next" (Далее).
  7. На странице "Ready to Install the Application" (Начало установки) нажмите кнопку "Next" (Далее), чтобы перейти к копированию файлов на диск.
  8. Нажмите "Finish" (Готово).

Для использования программы активации сетевой лицензии

  1. В меню "Пуск" (Windows) выберите "Все программы" (или "Программы") [image] Autodesk [image] Network License Manager [image] AutoCAD 2007 "Программа активации сетевой лицензии".
  2. На странице "Obtain a Network License" (Получение сетевой лицензии) ознакомьтесь с принципами работы утилиты и системными требованиями к ее использованию. Затем нажмите "Next" (Далее).
  3. На странице "Server Information" (Сведения о сервере) введите серийный номер продукта.
    Замечание В случае изменения существующего файла лицензии или получения новой лицензии для существующего продукта может отобразиться ранее введенная информация. Убедитесь, что отображается именно тот серийный номер, который необходимо лицензировать. Если это не так, введите правильный серийный номер.
  4. В разделе "License Server Model" (Модель сервера лицензий) выберите модель сервера лицензий. Чтобы узнать подробнее об имеющихся вариантах модели, можно воспользоваться кнопкой с вопросительным знаком.
  5. В поле "Server Host Name" (Имя хоста) ввести имя хоста сервера или воспользуйтесь кнопкой [...] для получения имен из сети.
  6. Для каждого имени хоста, введенного на предыдущем этапе, заполните поле "Host ID" (ID хоста) с помощью кнопки "Lookup" (Выбрать), или введите значения вручную.
    Замечание Если на сервере установлено несколько сетевых адаптеров, необходимо выбрать тот из них, который соответствует физическому устройству. Для того чтобы определить, какой из адаптеров соответствует физическому устройству, нужно ввести ipconfig /all в командной строке Windows и просмотреть информацию в поле "Описание", расположенном над каждым физическим адресом. Если физических сетевых адаптеров несколько, можно использовать любой из них; для этого необходимо, чтобы его имя выводилось в список командой ipconfig /all. Логические устройства (VPN-адаптеры, PPP-адаптеры, модемы и др.) могут также попасть в указанный выше список, но для работы с лицензиями они не годятся.
  7. Если в пункте 4 было выбрано "Distributed Server" (Распределенный сервер), появляется поле "Seats" (Рабочие места). В этом поле нужно ввести количество рабочих мест, обслуживаемых каждым сервером лицензий, а затем нажать кнопку "Next" (Далее).
  8. На странице "Confirm Server Information" (Подтверждение сведений о сервере) просмотрите введенную информацию и нажмите "Next" (Далее).
  9. Если отобразится страница "Register and License Your Autodesk Product" (Регистрация продукта Autodesk и получение лицензии на него), выполнить следующие действия, после чего нажмите кнопку "Next" (Далее).
    • Для параметра "Регистрация продукта выполняется на" установите значение "Организация" или "Частное лицо".
    • В поле "Select Country or Region" (Выбор страны или территории) выберите страну или территорию проживания.
    • Установите опцию "Is This an Upgrade" (Продукт обновляется с прежней версии) в положение "Yes" (Да) или "No" (Нет).
  10. Если отобразится страница "Registration Information" (Регистрационные данные), введите пользовательские регистрационные данные и нажмите "Next" (Далее).
  11. Если отобразится страница "Confirm Information" (Подтверждение данных), проверьте регистрационные данные и нажмите "Next" (Далее).
  12. Если отобразится страница "Connecting" (Связь с Интернетом), нажмите "Next" (Далее), чтобы подключиться к Интернету и получить сетевую лицензию.
  13. На странице "Полученные лицензии" укажите место для сохранения файла лицензии в поле "Сохранить файл лицензий для [computer name] в" или найдите его на диске с помощью кнопки "Обзор".
    Замечание Рекомендуется сохранять файл лицензий там же, где установлен Диспетчер сетевых лицензий.
  14. Если уже имеется файл лицензий от другого продукта Autodesk, выберите одну из следующих опций:
    • Вставить информацию о новой лицензии в имеющийся файл. Добавление сведений о новой лицензии в существующий файл лицензий.
    • Заменить существующий файл лицензий. Полная замена содержимого существующего файла лицензий сведениями о новой лицензии. Этот параметр следует выбирать только в том случае, если все остальные лицензии в файле действительно больше не нужны.
  15. Нажмите "Next" (Далее).
  16. На странице "Активация лицензии успешно выполнена" нажмите кнопку "Печать", чтобы вывести информацию о лицензии на печать, или нажмите "Готово" для завершения групповой операции и выхода из программы активации сетевой лицензии.


Настройка сервера лицензий [Руководство сетевого администратора AutoCAD: ]

Установка и использование программы активации сетевой лицензии
Настройка сервера лицензий
Настройка и распространение программы
Настройка сервера лицензий

Настройка сервера лицензий осуществляется таким образом, чтобы можно было управлять лицензиями на продукт Autodesk, полученными с помощью программы активации сетевой лицензии. Для настройки параметров сервера используется утилита lmtools.exe.

Для настройки параметров сервера лицензий

  1. В меню "Пуск" (Windows) выберите "Все программы" (или "Программы") [image] Autodesk [image] Network License Manager [image] LMTOOLS.
  2. На вкладке "Service/License File" (Службы/Файлы лицензии)программы Lmtools установите переключатель в положение "Configure Using Services" (Настроить, используя службы).
  3. Перейдите на вкладку "Config Services" (Настроить службу).
  4. На вкладке "Config Services" (Настроить службу) в списке "Service Name" (Имя службы) выберите службу или выполните одно из следующих действий:
    • Убедитесь, что в списке выбрана именно та служба, которую предполагается использовать для управления лицензиями.
    • Если список пуст, введите имя службы, которую предполагается использовать для управления лицензиями.
    ЗамечаниеЕсли для управления лицензиями имеется несколько поставщиков программного обеспечения с использованием FLEXlm®, в списке "Имя службы" отображается несколько опций.
  5. В поле "Path to Lmgrd.exe File" (Путь к файлу Lmgrd.exe) задайте путь к демону Network License Manager (lmgrd.exe), или найдите его с помощью кнопки "Browse" (Обзор).

    По умолчанию этот демон устанавливается в папку \Program Files\Autodesk Network License Manager.

  6. В поле "Path to the License File" (Путь к файлу лицензий) введите путь к файлу лицензий или найдите его с помощью кнопки "Browse" (Обзор).
  7. В поле "Path to the Debug Log File" (Путь к файлу отладочного журнала) введите путь, по которому формируется отладочный журнал, или найдите с помощью кнопки "Browse" (Обзор) существующий журнал.
  8. Для запуска lmgrd.exe в качестве сервисной программы установите флажок "Использовать службы".
  9. Для автоматической загрузки lmgrd.exe при запуске системы установите флажок "Start Server at Power Up".
  10. Для сохранения настроек с именем, заданным в пункте 4, нажмите кнопку "Save Service" (Сохранить службу). Затем нажмите "Да".
  11. Перейдите на вкладку "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз).
  12. На вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз) выполните одно из следующих действий:
    • Если службы для продуктов Autodesk еще не созданы, нажмите кнопку "Start Server" (Запустить сервер) для запуска сервера лицензий.
    • Если служба для продукта Autodesk уже создана и запущена, нажмите кнопку "ReRead" (Прочитать еще раз) для обновления Network License Manager всеми внесенными в файл лицензий или параметров изменениями.

      Сервер лицензий запускается и готов обрабатывать запросы клиентов.

  13. Закройте lmtools.exe.


Настройка и распространение программы [Руководство сетевого администратора AutoCAD: ]

Настройка сервера лицензий
Краткое руководство по сетевому администрированию
Создание общего сетевого ресурса
Настройка и распространение программы

После подготовки к развертыванию и запуска Диспетчера сетевых лицензий (Network License Manager) и программы активации сетевой лицензии можно приступить к настройке и распространению этой программы с помощью Мастера сетевой установки с учетом выбора способа развертывания.

Темы в этом разделе

  • Создание общего сетевого ресурса
  • Доступ к Мастеру развертывания
  • Использование Мастера развертывания для настройки развертывания
  • Развертывание этой программы


Создание общего сетевого ресурса [Руководство сетевого администратора AutoCAD: ]

Настройка и распространение программы
Настройка и распространение программы
Доступ к Мастеру развертывания
Создание общего сетевого ресурса

Общий сетевой ресурс представляет собой папку установки, доступную для пользователей компьютеров в сети. О местоположении папки пользователям сообщается при установке программы. Создайте сетевую папку, которая будет использоваться Мастером развертывания при создании развертывания для клиента.

ЗамечаниеДля создания общего сетевого ресурса требуются разрешения на изменение и чтение файлов. Пользователи должны иметь разрешение на чтение из общего сетевого ресурса и права администратора на рабочей станции, на которую устанавливается программа.

Для создания общего сетевого ресурса

  1. Нажмите правую кнопку мыши на значке соответствующей папки. Выберите "Доступ" из контекстного меню.
  2. В диалоговом окне "Properties" (Свойства) <folder name> на вкладке "Sharing" (Доступ) выберите параметр "Share This Folder" (Открыть общий доступ к этой папке).
  3. Установите необходимые полномочия и другие параметры общего доступа, затем нажмите "ОК".


Доступ к Мастеру развертывания [Руководство сетевого администратора AutoCAD: ]

Создание общего сетевого ресурса
Настройка и распространение программы
Использование Мастера развертывания для настройки развертывания
Доступ к Мастеру развертывания

Доступ к Мастеру развертывания выполняется из обозревателя диска двумя способами: Можно запустить мастер непосредственно из обозревателя или установить Мастер, а затем запустить его с жесткого диска.

  • Запуск Мастера развертывания из обозревателя диска. Мастер развертывания запускается непосредственно из обозревателя без установки Мастера на жесткий диск. Все настройки, выполняемые при запуске Мастера развертывания из обозревателя диска, сохраняются, поэтому при следующем запуске страницы Мастера автоматически заполняются данными. При запуске Мастера развертывания из обозревателя диска можно сохранить версии Мастера развертывания, установленные на жестком диске. Для запуска Мастера развертывания из Мультимедийного обозревателя необходимо вставить диск в привод компакт-дисков.
  • Установка Мастера развертывания Программа установки Мастера развертывания переносит с жесткого диска файлы, необходимые для запуска Мастера развертывания, в указанное местоположение. После установки Мастера развертывания его можно запускать без компакт-диска с программой. Мастер развертывания AutoCAD 2007 нельзя использовать для создания развертываний предыдущих версий программы. Перед установкой Мастера развертывания AutoCAD 2007 необходимо удалить любые установленные мастера развертывания.

Запуск Мастера развертывания из обозревателя диска

  1. В обозревателе диска раскройте вкладку "Установка".
  2. На вкладке "Установка" выберите либо "Автономная установка на несколько пользователей", либо "Сетевое развертывание".
  3. В области "Установка мастера развертывания" нажмите "Запуск с Мультимедийного обозревателя".
  4. Следуйте инструкциям, описанным в Использование Мастера развертывания.

Чтобы установить Мастер развертывания

  1. В обозревателе диска откройте вкладку "Установка".
  2. На вкладке "Установка" выберите либо "Автономная установка на несколько пользователей", либо "Сетевое развертывание".
  3. В разделе "Установка мастера развертывания" нажмите кнопку "Установить".
  4. В мастере развертывания на начальной странице нажмите кнопку "Next" (Далее).
  5. На странице "Лицензионный договор" прочтите лицензионный договор, установите флажок "I accept" (Принимаю) и нажмите "Далее".
    ЗамечаниеВ случае несогласия с условиями договора нужно нажать кнопку "Cancel" (Отмена) для отмены установки.
  6. На странице "Destination Folder" (Папка для установки) выберите папку для установки Мастера развертывания. Выполните одно из следующих действий:
    • Нажмите "Next" (Далее), чтобы принять папку, заданную по умолчанию (C:\Program Files\Autodesk Deployment Wizard\ ).
    • Нажмите "Обзор" для указания другой папки для установки мастера развертывания, или введите путь вручную. Нажмите "ОК", а затем "Next" (Далее).
  7. На странице "Ready to Install the Application" (Начало установки) нажмите кнопку "Next" (Далее). Мастер развертывания устанавливается в выбранной папке.
  8. Нажмите "Finish" (Готово).


Использование Мастера развертывания для настройки развертывания [Руководство сетевого администратора AutoCAD: ]

Доступ к Мастеру развертывания
Настройка и распространение программы
Развертывание этой программы
Использование Мастера развертывания для настройки развертывания

С помощью Мастера развертывания создается папка сетевого развертывания, из которой впоследствии другие пользователи смогут установить программу на свои компьютеры.

ЗамечаниеВ следующей процедуре показан один из способов настройки развертывания с помощью Мастера развертывания. Приводится описание процедуры сетевого развертывания с одним сервером для типовой клиентской установки без адаптаций. Информацию обо всех возможностях мастера развертывания см. в Использование Мастера развертывания.

Использование Мастера развертывания

  1. Выполните одно из следующих действий:
    • Мастер развертывания установлен: в меню "Пуск" (Windows) выберите "Все программы" (или "Программы") [image] Autodesk [image] "Мастер развертывания".
    • Мастер развертывания запущен из мультимедийного обозревателя: перейдите к следующему шагу.
  2. На стартовой странице Мастера развертывания выберите "Create an Administrative Image" (Создать главный установочный образ), а затем нажмите кнопку "Next" (Далее).
  3. На странице "Create Administrative Image" (Создание главного установочного образа) введите в поле "Select Autodesk Installer (MSI) File" (Расположение MSI-файла) путь к файлу acad.msi. Этот файл является основой для создания установочного образа. Можно также нажать кнопку [...] и найти файл вручную. Файл находится на установочном компакт-диске продукта. Найти файл acad.msi можно в папке CDROM:\BIN\ACADFeui.
  4. В поле "Расположение главного установочного образа" введите имя существующей сетевой папки, в которой будет создан образ, или нажмите кнопку […] для выбора папки на сетевом диске. Из этой папки пользователи будут устанавливать программу на свои рабочие станции.
    ЗамечаниеПодробнее о создании общих сетевых ресурсов см. Создание общего сетевого ресурса.
  5. Нажмите "Далее". На странице "Create or Modify Deployment" (Создание/редактирование папки развертывания) выберите "Create a Deployment" (Создать папку развертывания).
  6. В поле "Имя нового развертывания" введите наименование нового развертывания. Это наименование будет присвоено ярлыку, с помощью которого пользователи будут устанавливать продукт. Затем нажмите "Далее".
  7. На странице "Записать в журнал" в поле "Папка журнала" укажите папку для создания журнала, задав UNC-имя (универсальное соглашение об именовании) или жестко заданный сетевой путь. Файл сетевого журнала использовать не обязательно.
    ЗамечаниеСетевой журнал должен располагаться в общедоступной сетевой папке. Пользователи, устанавливающие программу, должны иметь разрешение на изменение файлов в этой папке. При отсутствии такого разрешения запись в файл журнала невозможна.
  8. Если нужно создавать клиентский журнал, установите флажок "Create Client Log" (Вести клиентский журнал). Нажмите кнопку "Next" (Далее).
  9. На странице "Выбор варианта установки" выберите опцию "С сетевой лицензией". Нажмите кнопку "Далее".
  10. На странице "Конфигурация серверов" выберите "Один сервер лицензий". Нажмите "Next" (Далее).
    ЗамечаниеПодробные инструкции по всем типам установок и серверов см. в Выбор варианта установки.
  11. На странице "Конфигурация с одним сервером" введите имя сервера, на котором будет запускаться Network License Manager, или выберите сервер, нажав кнопку […].
  12. Введите ID хоста сервера в поле "Server Host ID" или нажмите "Lookup" (Выбрать) для автоматического заполнения. Затем нажмите "Далее".
  13. В поле "Client Installation Location" (Путь к программе на станциях-клиентах) на странице "Client Installation Path" (Местоположение клиентской установки) введите путь к папке, которая будет использоваться для установки программы. Пусть установки по умолчанию C:\Program Files\AutoCAD 2007.
  14. Если нужно запретить пользователям изменять опции установки, следует установить флажок "Client Installations Will Be Run in Silent Mode" (Недиалоговая клиентская установка). Затем нажмите "Далее".
  15. Выберите "Typical" (Типовая) на странице "Client Setup Type" (Вариант клиентской установки). Нажмите "Next" (Далее).
  16. Нажмите кнопку "Next" (Далее) на странице "Install Additional Files" (Установка дополнительных средств).
  17. Нажмите кнопку "Next" (Далее) на странице "Additional Client Settings" (Дополнительные клиентские настройки).
  18. Нажмите кнопку "Next" (Далее) на странице "Search Paths and File Locations" (Пути поиска и папки для файлов).
  19. Нажмите кнопку "Next" (Далее) на странице "Install Additional Files" (Установка дополнительных файлов).
  20. На странице "Серийный номер" введите серийный номер продукта. Затем нажмите "Далее".
  21. На странице "Персональные данные" ввести сведения о пользователе. Затем нажмите "Далее".
    ЗамечаниеСтраница "Персональные данные" используется для ввода данных, указывающих, кто обладает правом на использование данного экземпляра программы. Указанные здесь сведения в дальнейшем изменить будет нельзя. Они выводятся в окне информации о AutoCAD 2007 (меню "Справка" [image] "О программе") на всех рабочих станциях с установкой развертывания. Так как изменить эту информацию можно только путем переустановки программы, необходимо сразу же удостовериться, что вводимые данные верны.
  22. Нажмите кнопку "Далее" на странице "Обновление по сети".
  23. На странице "Пользовательский отчет об ошибках" нажмите "Далее".
  24. На странице "DC Online" (Интернет-модуль Design Center) нажмите кнопку "Next" (Далее).
  25. На странице "Доступ к центру подписки" нажмите кнопку "Далее".
  26. На странице "Подтверждение" подтвердите заданные установочные настройки и нажмите кнопку "Далее".

    Если требуется изменить какие-либо из заданных настроек, нажмите кнопку "Back" (Назад).

    ЗамечаниеМожно сохранить информацию с данной страницы, выделив текст, скопировав его в буфер обмена и вставив затем в текстовый файл (например в Блокноте Windows). Созданный файл рекомендуется сохранить в той же папке и под тем же именем, что было выбрано для папки развертывания. Так следует поступать, например, в случае, если необходимо иметь информацию обо всех настройках папки развертывания.
  27. На странице "Установка завершена" нажмите кнопку "Готово".


Развертывание этой программы [Руководство сетевого администратора AutoCAD: ]

Использование Мастера развертывания для настройки развертывания
Настройка и распространение программы
Требования к системе
Развертывание этой программы

Пользователь может выбрать несколько методов развертывания программы. По умолчанию папка развертывания размещается в сети.

  • Общая папка развертывания. Пользователи запускают установку нажатием ярлыка, созданного Мастером развертывания на шаге 4 процедуры Использование Мастера развертывания для настройки развертывания (например: \\Server1\Autodesk\deployment\AutoCAD 2007). Программа устанавливается на локальных компьютерах пользователей, на рабочих столах этих компьютеров появляется ярлык программы.
ЗамечаниеПользователи должны иметь разрешение на чтение из общего сетевого ресурса и права администратора на рабочей станции, на которую устанавливается программа.
  • MS-анонсирование. См. Анонсирование.
  • Использование сценариев. См. Использование сценариев для развертывания программы.
  • Объекты групповой политики (GPO). См. Использование групповой политики для установки из папки развертывания.
  • Microsoft System Management Server (SMS). См. Использование Microsoft Systems Management Server для установки развертывания .
  • Программа создания образов. См. Распространения программы с использованием программы создания образов.


Требования к системе [Руководство сетевого администратора AutoCAD: ]

Развертывание этой программы
Требования к системе для данной программы
Требования к системе

В данной главе приведены требования к системе, необходимые для создания установочных образов, а также требования к серверу сетевых лицензий и рабочим станциям.

Темы в этом разделе

  • Требования к системе для данной программы


Требования к системе для данной программы [Руководство сетевого администратора AutoCAD: ]

Требования к системе
Требования к системе
Развертывание программы
Требования к системе для данной программы

Перед установкой программы в сети необходимо убедиться, что серверы и клиентские рабочие станции удовлетворяют, по крайней мере, минимальным требованиям, рекомендуемым для создания развертывания.

Требования к системе для создания установочных образов, серверу лицензий и клиентским рабочим станциям приведены ниже.

Требования к аппаратным средствам и программному обеспечению для создания главного установочного образа
Элемент | Требования | Замечания
Жесткий диск | 750 Мбайт (рекомендуется) | Главный установочный образ следует создавать на сетевом диске, доступном для всех пользователей, которым необходим AutoCAD.

Требования к аппаратным средствам и программному обеспечению сервера лицензий
Элемент | Требования | Замечания
Операционная система | Windows Server 2003 Windows XP Professional с пакетом обновления 1 или 2 Windows 2000 Server Edition Windows 2000 с пакетом обновления 4 | Network License Manager поддерживает только сети Ethernet.
Компьютер/процессор | Pentium III или выше 450 МГц (минимум) |
Сетевой адаптер | Совместимый с имеющейся инфраструктурой сети Ethernet | Network License Manager поддерживает различные сетевые карты.
Коммуникационный протокол | TCP/IP | Network License Manager работает с пакетами типа TCP.
Требования к аппаратным средствам и программному обеспечению для рабочих станций-клиентов
Элемент | Требования | Замечания
Операционная система | Windows® XP Professional с пакетом обновления SP 1 или 2 Windows XP Home с пакетом обновления 1 или 2 Windows XP Tablet PC с пакетом обновления SP 2 Windows 2000 с пакетом обновления SP 3 или 4 (рекомендуется SP 4) | Рекомендуется устанавливать локализованные версии AutoCAD на операционные системы, чей язык интерфейса совпадает по кодовой странице с языком AutoCAD. Кодовая страница обеспечивает поддержку наборов символов, используемых в различных языках.
Обозреватель Интернета | Microsoft Internet Explorer 6.0 с пакетом обновления SP 1 (или более поздней версии) | Невозможно установить AutoCAD, если на рабочей станции не установлен обозреватель Microsoft Internet Explorer 6.0 с пакетом обновления 1 (или более поздней версии). Internet Explorer можно загрузить с сайта корпорации Microsoft: http://www.microsoft.com/downloads/
Процессор | Pentium III или IV (рекомендуется Pentium IV) 800 МГц |
ОЗУ | 512 МБ (рекомендуется) |
Видео | 1024 x 768 VGA с цветовой палитрой True Color (минимум) | Видеоадаптер должен поддерживаться системой Windows.
Жесткий диск | Установка 750 Мбайт |
Устройство указания | Мышь, трекбол или иное устройство |
Дисковод CD-ROM | Любой (только для установки программы) |
Необязательное аппаратное обеспечение | 3D видеоадаптер, совместимый с Open GL® Принтер или плоттер Дигитайзер Модем или подключение к Интернету через локальную сеть Сетевой адаптер |
Дополнительные рекомендации по использованию 3D среды
Элемент | Требования | Замечания
Операционная система | Windows® XP Professional с пакетом обновления SP 2 | Рекомендуется устанавливать локализованные версии AutoCAD на операционные системы, чей язык интерфейса совпадает по кодовой странице с языком AutoCAD. Кодовая страница обеспечивает поддержку наборов символов, используемых в различных языках.
Процессор | 3,0 ГГц или выше |
ОЗУ | 2 Гбайт (или более) |
Графический адаптер | для рабочей памяти с объемом памяти не менее 128 Мбайт и поддержкой OpenGL | Подробнее о протестированных и сертифицированных графических адаптерах можно узнать в Интернете по адресу: www.autodesk.com/autocad-graphicscard
Жесткий диск | 2 Гбайт (в дополнение к 750 Мбайтам, необходимым для установки) |


Развертывание программы [Руководство сетевого администратора AutoCAD: ]

Требования к системе для данной программы
Подготовка к сетевому развертыванию
Развертывание программы

В данной главе описан процесс установки Мастера развертывания на компьютер. Этот Мастер позволяет создать или изменить развертывание, с помощью которого пользователи устанавливают программу на свои рабочие станции.

Темы в этом разделе

  • Подготовка к сетевому развертыванию
  • Доступ к Мастеру развертывания
  • Использование Мастера развертывания
  • Добавление программы Autodesk Vault 5 к папке развертывания (только для подписчиков)
  • Представление главного установочного образа
  • Удаление программы


Подготовка к сетевому развертыванию [Руководство сетевого администратора AutoCAD: ]

Развертывание программы
Развертывание программы
Доступ к Мастеру развертывания
Подготовка к сетевому развертыванию

Установка этой программы в сети должна быть тщательно спланирована и выполнена аккуратно. Выбор типа установки зависит как от инфраструктуры сети, так и от требований, предъявляемых клиентами.

В мастере развертывания необходимо выбрать один из следующих вариантов установки:

  • Автономная установка (один серийный номер для одного пользователя). Диспетчер сетевых лицензий Network License Manager в данном случае не используется. В случае автономной установки производится установка, регистрация и активация программы на каждой рабочей станции.
  • Автономная установка на несколько пользователей. Регистрационные данные собираются на страницах "Регистрация" Мастера развертывания. После первой активации с помощью серийного номера для автономной установки на нескольких пользователей активация выполняется автоматически для всех рабочих станций в зависимости от этого развертывания, если эти рабочие станции подключены к Интернету. В Мастере развертывания выберите параметр "Автономная установка".
  • С сетевой лицензией. При этом программа устанавливается на рабочие станции вместе с файлами и параметрами реестра, которые обеспечивают взаимодействие с Диспетчером сетевых лицензий. В Диспетчере сетевых лицензий можно разрешить доступ к лицензиям. Для работы программы после ее сетевой установки на рабочую станцию не требуется индивидуальная активация. Лицензии на программу распределяются, по крайней мере, с одного сервера.

Перед запуском Мастера развертывания необходимо выполнить следующие действия:

  • Проверка системных требований. Убедиться, что сеть, серверы и рабочие станции соответствуют требованиям к аппаратному и программному обеспечению. См. Требования к системе для данной программы.
  • Установка и активация Диспетчера сетевых лицензий Network License Manager. Если планируется работа пользователей с сетевыми лицензиями на программу, следует ознакомиться с Руководством по сетевому лицензированию для получения более подробных сведений о настройке серверов лицензий. Руководство по сетевому лицензированию можно найти в обозревателе диска и в справочной системе.
  • Создание общего сетевого ресурса. Общий сетевой ресурс представляет собой папку установки, доступную для пользователей компьютеров в сети. Создайте сетевую папку, которая будет использоваться мастером развертывания при создании развертывания клиента. Пользователи должны иметь доступ к этому ресурсу для установки программы. Подробнее о создании общих сетевых ресурсов см. Создание общего сетевого ресурса.
    ЗамечаниеДля создания общего сетевого ресурса требуются разрешения на изменение и чтение файлов. Пользователи должны иметь разрешение на чтение из общего сетевого ресурса и права администратора на рабочей станции, на которую устанавливается программа.

После выполнения этих действий можно переходить к размещению и запуску Мастера развертывания.


Использование Мастера развертывания [Руководство сетевого администратора AutoCAD: ]

Доступ к Мастеру развертывания
Развертывание программы
Запуск Мастера развертывания
Использование Мастера развертывания

С помощью Мастера развертывания создается папка сетевого развертывания, из которой впоследствии другие пользователи смогут устанавливать программу на свои компьютеры. Для создания различных папок и типов развертывания, удовлетворяющих требованиям пользователей и нуждам организации, в Мастере можно выбирать соответствующие параметры.

С помощью Мастера развертывания можно выполнить следующие действия:

  • Создание и редактирование папки развертывания.
  • Применение пакета обновления к развертыванию.
  • Добавление дополнительных файлов к развертыванию.
  • Изменение путей поиска и расположения файлов.
ЗамечаниеИз-за большого количества вариантов создания и настройки папок развертывания Мастер развертывания содержит множество страниц и параметров для выбора. Поэтому следует заранее выделить достаточное время для запуска Мастера развертывания за один сеанс. Все подготовительные операции необходимо завершить до запуска Мастера развертывания. Подробнее вопросы подготовки изложены в Подготовка к сетевому развертыванию.

Работая с Мастером развертывания, можно выполнить следующие операции:

  1. Запуск Мастера развертывания
  2. Создание и редактирование главного установочного образа
  3. Создание и редактирование папки развертывания
  4. Указание пути к файлу журнала
  5. Выбор варианта установки
  6. Задание местоположения клиентской установки
  7. Выбор варианта клиентской установки
  8. Установка дополнительных средств (необязательная)
  9. Установка дополнительных клиентских настроек (необязательная)
  10. Изменение путей к файлам (необязательное)
  11. Установка дополнительных файлов (необязательная)
  12. Указание серийного номера продукта
  13. Указание сведений о пользователе
  14. Разрешение обновления по Интернету (необязательное)
  15. Пользователи получают уведомления об обработке отчетов об ошибках
  16. Активизация DesignCenter Online (необязательная)
  17. Активизация Центра подписки (необязательная)
  18. Регистрация
  19. Подтверждение и завершение настройки

Темы в этом разделе

  • Запуск Мастера развертывания
  • Создание и редактирование главного установочного образа
  • Создание и редактирование папки развертывания
  • Указание пути к файлу журнала
  • Выбор варианта установки
  • Задание местоположения клиентской установки
  • Выбор варианта клиентской установки
  • Установка дополнительных средств (необязательная)
  • Установка дополнительных клиентских настроек (необязательная)
  • Изменение путей к файлам (необязательное)
  • Установка дополнительных файлов (необязательная)
  • Указание серийного номера продукта
  • Указание сведений о пользователе
  • Разрешение обновления по Интернету (необязательное)
  • Пользователи получают уведомления об обработке отчетов об ошибках
  • Активизация DesignCenter Online (необязательная)
  • Активизация Центра подписки (необязательная)
  • Регистрация
  • Подтверждение и завершение настройки


Запуск Мастера развертывания [Руководство сетевого администратора AutoCAD: ]

Использование Мастера развертывания
Использование Мастера развертывания
Создание и редактирование главного установочного образа
Запуск Мастера развертывания

После установки Мастера развертывания его необходимо запустить для настройки развертывания. Подробнее об установке Мастера развертывания см. в Доступ к Мастеру развертывания .

Чтобы запустить Мастер развертывания

  • В меню "Пуск" (Windows) следует выбрать "Все программы" (или "Программы") [image] Autodesk [image] "Мастер развертывания".


Создание и редактирование главного установочного образа [Руководство сетевого администратора AutoCAD: ]

Запуск Мастера развертывания
Использование Мастера развертывания
Создание и редактирование папки развертывания
Создание и редактирование главного установочного образа

С помощью Мастера развертывания можно создать главный установочный образ или изменить уже существующий. Главный установочный образ представляет собой набор доступных для пользователей сети файлов, созданный Мастером развертывания и используемый для установки программы на рабочие станции.

Создание главного установочного образа. Для создания главного установочного образа нужно задать сетевую папку, в которой будет храниться образ. Сетевая папка должна быть доступна для всех пользователей, работающих с продуктом.

Редактирование главного установочного образа. Для редактирования главного установочного образа нужно выбрать существующий образ и внести в него изменения. На этом этапе можно применить процедуру обновления или добавить дополнительные файлы, которые не являются частью основного образа. Можно также изменить каталог установки с диска C на диск D.

Для создания главного установочного образа

  1. На стартовой странице Мастера развертывания выберите "Создать главный установочный образ", затем нажмите кнопку "Далее".

  2. На странице "Создание главного установочного образа" введите в поле "Расположение MSI-файла" путь к файлу acad.msi. Этот файл является основой для создания установочного образа. Файл находится на установочном компакт-диске продукта. Найти файлacad.msi можно в папке CDROM:\BIN\ACADFeui.

  3. В поле "Расположение главного установочного образа" введите имя существующей сетевой папки, в которой будет создан образ, или нажмите кнопку […] для выбора папки в структуре дисков. Из этой папки пользователи будут устанавливать программу на свои рабочие станции.
  4. Для обновления установочного образа при его изменении выполните следующее:
    • Загрузите пакет обновления с Интернет-сайта поддержки программы Autodesk. Сведения по установке пакета обновления находятся в файле Readme. Пакет обновления должен быть в виде MSP-файла.
    • В диалоговом окне "Применить пакет обновления" введите путь к пакету обновления (включая расширение .msp) или нажмите кнопку [...] и выберите файл MSP.

    Обычно обновление включается в исполняемый файл пакета обновления, который можно загрузить с веб-сайта Autodesk. Для того, чтобы извлечь MSP-файл из исполняемого файла, следует запустить пакет обновления из командной строки Windows с параметром /e. Необходимо запомнить папку, в которую были извлечены файлы. Подробнее об использовании файла обновления см. в файле Readme для этого обновления.

    ЗамечаниеО наличии доступных пакетов обновления можно узнать на странице поддержки программ Autodesk по адресу http://support.autodesk.com/.
  5. Выполните одно из следующих действий:
    • Если для распространения установочного образа будет использоваться метод автоматического распространения (например объекты групповой политики), установить флажок "Объекты групповой политики для распространения развертывания". Если используется этот метод, пакет обновления должен быть внедрен в MSI-файл. В противном случае при распространении программы пакет обновления игнорируется. Подробнее об объектах групповой политики см. Использование групповой политики для установки из папки развертывания.
    • Чтобы "прикрепить" пакет обновления к MSI-файлу, а не внедрять его, снимите флажок "Объекты групповой политики для распространения развертывания". Данная опция используется в том случае, если требуется сохранить исходный MSI-файл.
  6. Нажмите кнопку "Далее" для перехода на страницу "Создание/редактирование папки развертывания".

Для редактирования главного установочного образа

  1. На начальной странице Мастера развертывания выберите "Изменить главный установочный образ", затем нажмите кнопку "Далее".

  2. На странице "Редактирование главного установочного образа" в поле "Расположение MSI-файла" выберите в сетевой папке с файлами главного установочного образа существующий MSI-файл. Из этой папки пользователи будут устанавливать программу на свои рабочие станции.

  3. Для обновления установочного образа при его изменении выполните следующее:
    • Загрузите пакет обновления с сайта поддержки программы Autodesk. Сведения по установке пакета обновления находятся в файле Readme. Чтобы использовать обновление при создании установочного образа, оно должно быть представлено в виде файла MSP.
    • В диалоговом окне "Применить пакет обновления" введите путь к пакету обновления (включая расширение .msp) или нажмите кнопку [...] и выберите файл MSP.
    ЗамечаниеЕсли опция "Применить пакет обновления" на этой странице не отображается, значит пакет обновления уже применен к установочному образу. Для добавления нового пакета обновления необходимо создать новый установочный образ.

    Обычно обновление включается в исполняемый файл пакета обновления, который можно загрузить с сайта Autodesk. Для того чтобы извлечь MSP-файл из исполняемого файла, следует запустить пакет обновления из командной строки Windows с параметром /e. Необходимо запомнить папку, в которую были извлечены файлы. Подробнее об использовании файла обновления см. в файле Readme для этого обновления.

    ЗамечаниеДля того чтобы узнать, существует ли обновление для конкретного продукта, следует посетить страницу Autodesk Product Support по адресу http://support.autodesk.com.
  4. Выполнить одно из следующих действий:
    • Если для распространения установочного образа будет использоваться метод автоматического распространения (например объекты групповой политики), установите флажок "Объекты групповой политики для распространения развертывания". Если используется этот метод, пакет обновления должен быть внедрен в MSI-файл. В противном случае при распространении программы пакет обновления игнорируется. Подробнее об объектах групповой политики см. Использование групповой политики для установки из папки развертывания.
    • Чтобы "прикрепить" пакет обновления к MSI-файлу, а не внедрять его, снимите флажок "Объекты групповой политики для распространения развертывания". Данная опция используется в том случае, если требуется сохранить исходный MSI-файл.
  5. Нажмите кнопку "Далее" для перехода на страницу "Создание/редактирование папки развертывания".


Создание и редактирование папки развертывания [Руководство сетевого администратора AutoCAD: ]

Создание и редактирование главного установочного образа
Использование Мастера развертывания
Указание пути к файлу журнала
Создание и редактирование папки развертывания

Папка развертывания содержит набор MST-файлов, с помощью которых можно изменять параметры установки программы. Для создания и редактирования папок развертывания используется Мастер развертывания.

Создать папку развертывания. Создание новой папки развертывания. Имя, заданное для новой папки, присваивается ярлыку, с помощью которого пользователи будут устанавливать продукт. Это же имя получает и файл MST.

Редактировать папку развертывания. Внесение изменений в существующую папку развертывания. Эта опция доступна только при наличии созданной ранее папки развертывания. Имя, заданное для данной папки, присваивается ярлыку, с помощью которого пользователи будут устанавливать продукт.

Для создания папки развертывания

  1. На странице "Создание и редактирование папки развертывания" Мастера развертывания выберите "Создать папку развертывания".

  2. В поле "Имя нового развертывания" введите имя нового развертывания. Это имя будет присвоено ярлыку, с помощью которого пользователи будут устанавливать продукт.
  3. Нажмите кнопку "Далее" для перехода на страницу "Запись в журнал".

Для редактирования папки развертывания

  1. На странице "Создание и редактирование папки развертывания" Мастера развертывания выберите "Редактировать папку развертывания".

  2. В списке "Выбор папки развертывания" выберите папку для редактирования.
  3. Нажмите кнопку "Далее" для перехода на страницу "Запись в журнал".


Указание пути к файлу журнала [Руководство сетевого администратора AutoCAD: ]

Создание и редактирование папки развертывания
Использование Мастера развертывания
Выбор варианта установки
Указание пути к файлу журнала

Программа поддерживает два типа файлов журнала, с помощью которых можно просматривать информацию о развертывании и установке.

  • Сетевой журнал. Файл сетевого журнала содержит записи о всех рабочих станциях, использующих развертывание. На странице Мастера развертывания "Запись в файл журнала" укажите, следует или нет создавать файл сетевого журнала. В журнале содержатся имена пользователей, имена рабочих станций и сведения о состоянии установки. Содержимое этого файла отражает текущее состояние и сведения о неполадках в процессе установки (например нехватке дискового пространства или недостаточных полномочиях). Сетевому журналу присваивается имя, совпадающее с именем папки развертывания. Можно указать папку для создания журнала, задав UNC-имя (универсальное соглашение об именовании) или жестко заданный сетевой путь.
    ЗамечаниеСетевой журнал должен располагаться в общедоступной сетевой папке. Пользователи, устанавливающие программу, должны иметь разрешение на изменение файлов в этой папке. При отсутствии такого разрешения запись в файл журнала невозможна.
  • Клиентский журнал. Содержит подробную информацию об установке для каждой рабочей станции. Эта информация может быть полезна для диагностики ошибок установки. Файл клиентского журнала находится в папке Temp каждой рабочей станции. Клиентскому журналу присваивается имя, совпадающее с именем папки развертывания.

Для задания пути к файлу журнала

  1. Для создания файла сетевого журнала в мастере развертывания на странице "Запись в файл журнала" установите флажок "Создать сетевой журнал" и укажите папку его расположения. По умолчанию этот флажок установлен.

  2. Если нужно создавать клиентский журнал, следует установить флажок "Вести клиентский журнал".
  3. Нажмите кнопку "Далее" для перехода на страницу "Выбор варианта установки".


Выбор варианта установки [Руководство сетевого администратора AutoCAD: ]

Указание пути к файлу журнала
Использование Мастера развертывания
Задание местоположения клиентской установки
Выбор варианта установки

Вариант установки задается при настройке параметров развертывания. В Мастере развертывания необходимо выбрать один из следующих вариантов установки:

  • С сетевой лицензией. При этом устанавливается программа на рабочие станции вместе с файлами и параметрами реестра, которые обеспечивают взаимодействие с Диспетчером сетевых лицензий Network License Manager. В Диспетчере сетевых лицензий можно разрешить доступ к лицензиям. Для работы программы после ее сетевой установки на рабочую станцию не требуется индивидуальная активация. Лицензии на программу распределяются, по крайней мере, с одного сервера.
  • Автономная установка. Выберите этот тип установки для автономной установки (один серийный номер для одного пользователя) или автономной установки для нескольких пользователей (один серийный номер для нескольких установок). Диспетчер сетевых лицензий в данном случае не используется. В случае автономной установки производится установка, регистрация и активация программы на каждой рабочей станции. При автономной установке для нескольких пользователей не требуется индивидуальная регистрация и активация на рабочих станциях, где используется программа. После первой активации с помощью серийного номера для автономной установки на нескольких пользователей активация выполняется автоматически для всех рабочих станций в зависимости от этого развертывания, если эти рабочие станции подключены к Интернету.
    ЗамечаниеПри наличии серийного номера автономной установки для нескольких пользователей можно использовать одну лицензию для нескольких пользователей программы.

Для выбора установки с сетевой лицензией

  1. На странице "Выбор варианта установки" Мастера развертывания выберите параметр "С сетевой лицензией". Нажмите "Далее".
  2. На странице "Конфигурация серверов" выберите подходящую конфигурацию серверов лицензий для Network License Manager.

    Доступны следующие конфигурации:

    • С одним сервером лицензий
    • С несколькими серверами лицензий
    • С резервными серверами лицензий

    Если Network License Manager уже использовался для создания конфигурации серверов лицензий, следует выбирать ту же конфигурацию. Если же конфигурация создается впервые, следует иметь в виду, что в Network License Manager и в Мастере сетевой установки она должна быть одинаковой.

    Подробней о моделях серверов лицензий см. “"Модели серверов лицензий"” в Руководстве по сетевому лицензированию в справочной системе и на вкладке "Документация" в обозревателе диска.

  3. Если в пункте 2 была выбрана конфигурация с одним сервером лицензий, введите на странице "Конфигурация с одним сервером" имя сервера, на котором будет запускаться Network License Manager, или выберите сервер, нажав кнопку […]. Введите идентификатор узла сервера в поле "Код узла сервера" или нажмите "Найти" для автоматического ввода. Нажмите кнопку "Далее" для перехода на страницу "Местоположение клиентской установки".

  4. Если в пункте 2 была выбрана конфигурация с несколькими серверами лицензий, введите на странице "Конфигурация с несколькими серверами" в поле "Имя сервера" имя одного из серверов, на которых будет запускаться Network License Manager. Имя сервера также можно выбрать, нажав кнопку […]. Введите идентификатор узла сервера в соответствующем поле или нажмите "Поиск", чтобы ввести его автоматически. Можно также нажать кнопку "Добавить", чтобы добавить ID хоста сервера. В списке "Пул серверов" с помощью стрелок "вверх" и "вниз" установить порядок поиска серверов рабочей станцией пользователя. Идентификатор узла сервера отображается в скобках рядом с его именем (для каждого сервера). Для данной конфигурации требуется указать, по крайней мере, два сервера. Нажмите кнопку "Далее" для перехода на страницу "Местоположение клиентской установки".

  5. Если в пункте 2 была выбрана конфигурация с резервными серверами лицензий, то на странице "Конфигурация с резервными серверами лицензий" нужно сначала ввести имя первого сервера пула (на котором будет запускаться Network License Manager). Сервер можно выбрать, нажав кнопку […]. Введите идентификатор узла сервера в поле "Код узла первого сервера". Чтобы ввести его автоматически, нажмите "Поиск". Затем введите имена и идентификаторы хостов остальных двух серверов, которые будут использоваться в качестве резервных. Нажмите кнопку "Далее" для перехода на страницу "Местоположение клиентской установки".

    ЗамечаниеЕсли неизвестны имя и идентификатор узла сервера, см. “Планирование конфигурации сервера лицензий” в Руководстве по сетевому лицензированию. Руководство можно найти в справочной системе и на вкладке "Документация" обозревателя диска.

Чтобы выбрать автономную установку или автономную установку на нескольких пользователей

  1. На странице "Выбор варианта установки" мастера развертывания следует выбрать параметр "Автономная установка".
  2. Нажмите кнопку "Далее" для перехода на страницу "Местоположение клиентской установки".


Задание местоположения клиентской установки [Руководство сетевого администратора AutoCAD: ]

Выбор варианта установки
Использование Мастера развертывания
Выбор варианта клиентской установки
Задание местоположения клиентской установки

Можно задать папку, в которую будут устанавливаться файлы программы на клиентской рабочей станции.

Для задания местоположения клиентской установки

  1. В поле "Путь к программе на станциях-клиентах" на странице "Местоположение клиентской установки" Мастера развертывания введите путь к папке, которая будет использоваться для установки программы.
  2. Если нужно запретить пользователям изменять опции установки, следует установить флажок "Недиалоговая клиентская установка".
  3. Нажмите кнопку "Далее" для перехода на страницу "Вариант клиентской установки".


Выбор варианта клиентской установки [Руководство сетевого администратора AutoCAD: ]

Задание местоположения клиентской установки
Использование Мастера развертывания
Установка дополнительных средств (необязательная)
Выбор варианта клиентской установки

От выбора варианта клиентской установки зависит набор доступных для установки компонентов программы.

  • Типовая. Установка наиболее часто используемых компонентов. Рекомендуется для большинства пользователей.
  • Выборочная. Установка только выбранных пользователем компонентов.

Для выбора варианта клиентской установки

  1. На странице "Вариант клиентской установки" Мастера развертывания выберите подходящий вариант: "Типовая" или "Выборочная". Нажмите "Далее".

  2. Если пользователь предпочел выборочную установку, появляется страница выбора компонентов. Будут установлены только те компоненты, которые пользователь задаст на ней. Следует отметить устанавливаемые компоненты и нажать кнопку "Далее".

    Доступны следующие конфигурации:

    • Базы данных. Средства доступа к базам данных.
    • Словари. Орфографические словари с поддержкой различных языков.
    • Шифрование чертежей.Возможность защищать чертежи паролем с помощью диалогового окна "Параметры безопасности".
    • Express Tools. Содержит средства поддержки и служебные программы.
    • Шрифты.Шрифты программы (шрифты True Type автоматически устанавливаются вместе с программой).
    • Библиотека материалов. Содержит более 300 профессионально сделанных материалов в виде палитр инструментов.
    • Перенос пользовательских настроек. Возможность переноса пользовательских настроек и адаптированных файлов из прежних версий. Подробней о переносе пользовательских настроек см. “Перенос пользовательских настроек” в Руководстве по однопользовательской установке.
    • Семинар по новым возможностям Видеоролики, практические упражнения и файлы примеров, предназначенные для изучения пользователями новых возможностей.
    • Утилита перемещения лицензий. Программа для перемещения однопользовательских лицензий между компьютерами (доступна только при развертывании отдельной версии программы на нескольких рабочих мест).
    • Диспетчер ссылок. Позволяет просматривать и редактировать пути к внешним файлам ссылок, связанным с чертежом.
    • Примеры. Файлы примеров для различных компонентов.
    • Текстуры. Текстуры для объектов.
    • Поддержка VBA. Вспомогательные файлы Microsoft Visual Basic for Applications.
    • Стандарты оформления. Средства проверки графических файлов на соответствие заданным стандартам.


Установка дополнительных средств (необязательная) [Руководство сетевого администратора AutoCAD: ]

Выбор варианта клиентской установки
Использование Мастера развертывания
Установка дополнительных клиентских настроек (необязательная)
Установка дополнительных средств (необязательная)

На странице "Установка дополнительных средств" можно выбрать установку при развертывании дополнительных утилит Express Tools и библиотеки материалов. Дополнительные утилиты Express Tools доступны в оригинальном виде (только на английском языке) и не поддерживаются. Обновления средств не производились. Двухбайтовые символы не поддерживаются.

Замечание Некоторые дополнительные утилиты Express Tools предыдущих версий (включая команду CHSPACE и большинство инструментов слоев) интегрированы в AutoCAD 2007. Полный список интегрированных средств см. в ответах на наиболее часто задаваемые вопросы в справочной системе дополнительных утилит Express Tools. Сведения о встроенных командах можно найти в справочной системе программы.

Установки дополнительных утилит Express Tools и библиотеки материалов

  1. В Мастере развертывания на странице "Установка дополнительных средств" средства Express Tools выбраны для установки по умолчанию. Снимите флажок "Установка дополнительные утилиты Express Tools", если эти утилиты не требуется включать в развертывание.

  2. По умолчанию флажок "Установка библиотеки материалов" снят. Установите флажок, если требуется включить в развертывание библиотеку материалов.
  3. Нажмите кнопку "Далее" для перехода на страницу "Пути поиска и папки для файлов".


Установка дополнительных клиентских настроек (необязательная) [Руководство сетевого администратора AutoCAD: ]

Установка дополнительных средств (необязательная)
Использование Мастера развертывания
Изменение путей к файлам (необязательное)
Установка дополнительных клиентских настроек (необязательная)

На странице "Установить дополнительные клиентские настройки" можно указать, следует ли продолжить установки на основе этого развертывания, если не установлен обозреватель Microsoft Internet Explorer, указать имя профиля по умолчанию, а также указать, требуется ли отобразить ярлык продукта на рабочем столе.

Чтобы установить дополнительные клиентские настройки

  1. В Мастере развертывания на странице "Дополнительные клиентские настройки" снимите флажок "Для установки необходим Internet Explorer", если не требуется перед установкой AutoCAD устанавливать Internet Explorer.
  2. В поле "Имя профиля" укажите имя профиля, устанавливаемого по умолчанию для всех пользователей, выполняющих развертывание.
  3. Снимите флажок "Поместить ярлык AutoCAD 2007 на рабочий стол", если не требуется размещать ярлык программы на рабочем столе.
  4. Нажмите "Далее".


Изменение путей к файлам (необязательное) [Руководство сетевого администратора AutoCAD: ]

Установка дополнительных клиентских настроек (необязательная)
Использование Мастера развертывания
Установка дополнительных файлов (необязательная)
Изменение путей к файлам (необязательное)

На странице "Пути поиска и папки для файлов" можно изменить пути поиска и доступа к некоторым файлам программы, которые используются по умолчанию. Потребность изменить установки по умолчанию может возникнуть по следующим причинам:

  • Если в среде САПР используется файл (например файл настройки или надстройки), отличный от файла, установленного программой по умолчанию, его можно указать на этой странице и не добавлять для каждой рабочей станции.
  • Пути к некоторым файлам, заданные по умолчанию, изменились в этой версии программы. С помощью этой страницы можно переместить файлы в те же папки, что и в более ранней версии программы.
ЗамечаниеПути поиска и папки файлов можно изменить для отдельных рабочих станций и после установки программы. Это делается с помощью диалогового окна "Настройка". Подробней см. "Указание путей поиска, имен и местоположения файлов” в Руководстве пользователя.

На этой странице можно выбрать одну из следующих опций:

  • Использовать стандартные настройки. Настройки по умолчанию для путей поиска и папок файлов не изменяются.
  • Изменить стандартные настройки. Возможность изменения путей к файлам по умолчанию.

Чтобы использовать настройки по умолчанию для путей поиска и папок файлов

  • На странице "Пути поиска и папки для файлов" мастера развертывания удостоверьтесь, что выбран параметр "Использовать стандартные настройки". Нажмите кнопку "Далее" для перехода на страницу "Установка дополнительных файлов".

Чтобы изменить настройки по умолчанию для путей поиска и папок файлов

  1. На странице "Пути поиска и папки для файлов" Мастера развертывания следует выбрать параметр "Изменить стандартные настройки".
  2. Нажмите кнопку "Настройки".
  3. На странице "Изменение настроек" в списке "Пути доступа, имена файлов и папки" нажмите значок "+" слева от выбранного элемента для раскрытия списка.

  4. Выберите элемент списка, далее выполнить одно из следующих действий:
    • Нажмите кнопку "Обзор" для выбора папки.
    • Для добавления нового элемента в список нажмите кнопку "Добавить".
    • Для удаления выбранного элемента из списка нажмите кнопку "Удалить".
    • Для перемещения выбранного элемента в списке на один уровень вверх или вниз нажмите соответственно кнопку "Вверх" или "Вниз".
    ЗамечаниеЭти кнопки доступны в зависимости от того, какой элемент был выбран в предыдущем пункте.
  5. После того как все пути к файлам будут настроены, нажмите кнопку "OK".
  6. На странице "Пути поиска и папки для файлов" нажмите кнопку "Далее" для перехода на страницу "Установка дополнительных файлов".


Установка дополнительных файлов (необязательная) [Руководство сетевого администратора AutoCAD: ]

Изменение путей к файлам (необязательное)
Использование Мастера развертывания
Указание серийного номера продукта
Установка дополнительных файлов (необязательная)

На странице "Установка дополнительных файлов" можно добавить файлы в развертывание. По умолчанию при развертывании эти файлы устанавливаются в папку установки программы на рабочей станции-клиенте. Если требуется, можно установить файлы в несколько папок.

На данной странице пользователь может выполнить следующие операции:

  • Указать для включения в развертывание дополнительные файлы (например файлы чертежей, процедру AutoLISP® или файлы сценариев).
  • Установить файлы различных типов в разные папки на рабочих станциях.
  • Добавить в папку установки вложенные папки (например папку с именем LSP с пользовательскими процедурами AutoLISP).
  • Добавить файлы в ту же папку, что и файлы программы (например примеры чертежей для проекта).
  • Добавить файлы в корневую папку установки.
ЗамечаниеЭти файлы рекомендуется устанавливать в папку, входящую в структуру папок программы. При этом имена дополнительных файлов не могут совпадать с именами файлов установленной программы. Например, невозможно включить в развертывание файл acad.cui.

Для установки дополнительных файлов

  1. В Мастере развертывания на странице "Установка дополнительных файлов" нажмите кнопку "Выбор файлов".

    В диалоговом окне "Выбор файлов" в области "Добавить файлы в список" можно добавить папки, диски и файлы к папке установки развертывания.

  2. Выполните одно из следующих действий:
    • Открывается диалоговое окно "Выбор файлов для добавления", в котором можно выбрать файлы для добавления в папку установки.
    • Нажмите кнопку "Добавить папку" для создания новой вложенной папки в папке установки.
    • Нажмите кнопку "Добавить диск" для добавления диска в папку установки.
    • Нажмите кнопку "Исключить" для исключения файла, папки или имени диска из места установки.
  3. Нажмите "ОК".
  4. На странице "Установка дополнительных файлов" нажмите кнопку "Далее" для перехода на страницу "Серийный номер".


Указание серийного номера продукта [Руководство сетевого администратора AutoCAD: ]

Установка дополнительных файлов (необязательная)
Использование Мастера развертывания
Указание сведений о пользователе
Указание серийного номера продукта

Чтобы запустить продукт, необходимо ввести его серийный номер в мастере развертывания. Серийный номер продукта можно найти на упаковке. Серийный номер состоит из префикса (трехзначное число), дефиса и кода (восьмизначное число).

Для указания серийного номера продукта

  1. На странице "Серийный номер" Мастера развертывания введите серийный номер продукта.

  2. Нажмите кнопку "Далее" для перехода на страницу "Персональные данные".


Указание сведений о пользователе [Руководство сетевого администратора AutoCAD: ]

Указание серийного номера продукта
Использование Мастера развертывания
Разрешение обновления по Интернету (необязательное)
Указание сведений о пользователе

Страница "Персональные данные" используется для ввода данных, указывающих, кто обладает правом на использование данного экземпляра программы. Указанные здесь сведения в дальнейшем изменить будет нельзя. Они выводятся в окне информации о <product name> (меню "Справка" [image] "О программе") на всех рабочих станциях с установкой развертывания. Так как изменить эту информацию можно только путем переустановки программы, необходимо сразу же удостовериться, что вводимые данные верны.

Для указания сведений о пользователе

  1. На странице "Персональные данные" введите сведения в поля.
    ЗамечаниеТребуется заполнить все поля на данной странице, но вводить в них можно любые сведения, которые предполагается сообщить пользователям, устанавливающим AutoCAD из данной папки развертывания.

  2. Нажмите кнопку "Далее" для перехода на страницу "Обновление по сети".


Разрешение обновления по Интернету (необязательное) [Руководство сетевого администратора AutoCAD: ]

Указание сведений о пользователе
Использование Мастера развертывания
Пользователи получают уведомления об обработке отчетов об ошибках
Разрешение обновления по Интернету (необязательное)

Продукты Autodesk можно обновлять по Интернету, загружая процедуры обновления при помощи Коммуникационного центра. После подключения к Интернету пользователь может проверить наличие обновлений. Если доступен пакет обновления, в строке состояние программы появляется соответствующее уведомление, пакет обновления можно загрузить непосредственно с сервера Autodesk или его можно изменить перед копированием на рабочие станции пользователей. Чтобы пользователи не получали обновлений или уведомлений, обновление по сети можно отключить.

ЗамечаниеВключить или отключить обновление по сети можно в Диспетчере интернет-компонентов, доступ к которому выполняется на вкладке "Установка" (при развертывании отдельной версии на несколько рабочих мест или сетевом развертывании) обозревателя диска.

Для разрешения и запрета уведомления об обновлениях

  1. На странице "Обновление по сети" выберите один из следующих параметров:
    • Запретить обновление по сети. При выборе этого параметра пользователи не смогут получать обновления продукта или уведомления о них с серверов Autodesk.
    • Получать обновления с сервера Autodesk. При выборе этой опции пользователи смогут получать обновления продукта и уведомления о них с сервера Autodesk.
    • Получать обновления с локального сервера. При выборе этой опции список обновлений можно получить на сервере локальной сети. В поле "Путь к локальному списку обновлений" нужно ввести путь к списку обновлений на сервере локальной сети, или найти список с помощью кнопки […]. Подробней об использовании списка обновлений можно узнать при установке Autodesk CAD Manager Tools 4.0 (доступ из обозревателя диска) в справочной системе Диспетчера интернет-компонентов.
      ЗамечаниеМожно назвать файл, который будет использовать для ввода информации о пакете обновления. Называя файл и присваивая ему расширение n .npl, создается файл-заменитель, а не собственно файл. В папке, заданной в поле "Путь к локальному списку обновлений", нужно создать текстовый файл с таким же именем, что было введено на данной странице.

  2. Нажмите кнопку "Далее" для перехода на страницу "DC Online".


Пользователи получают уведомления об обработке отчетов об ошибках [Руководство сетевого администратора AutoCAD: ]

Разрешение обновления по Интернету (необязательное)
Использование Мастера развертывания
Активизация DesignCenter Online (необязательная)
Пользователи получают уведомления об обработке отчетов об ошибках

Если AutoCAD неожиданное закрывается, пользователи могут отправить отчет об ошибке непосредственно в компанию Autodesk, что поможет выявить и устранить проблему. На странице "Пользовательский отчет об ошибках" можно указать, смогут ли пользователи получать уведомления из Autodesk после устранения ошибок.

ЗамечаниеВключить или отключить уведомление о пользовательских отчетах об ошибках можно в Диспетчере интернет-компонентов, доступ к которому выполняется на вкладке "Установка" (при развертывании отдельной версии на несколько рабочих мест или сетевом развертывании) мультимедийного обозревателя.

Пользователи получают уведомления об обработке отчетов об ошибках

  1. В Мастере развертывания на странице "Пользовательский отчет об ошибках" выполните следующее:
    • Установите флажок "Включить имя компьютера", чтобы включить в отчет имя компьютера пользователя. Имя компьютера включается в уведомления пользователям и отчеты, доступные для администратором подписки. По умолчанию этот флажок снят.
    • Установите флажок "Пользователи получают уведомления", чтобы пользователи знали о решении проблем и могли загрузить соответствующее обновление Autodesk. По умолчанию этот флажок установлен.
      ЗамечаниеДля установки обновлений компании Autodesk пользователи должны иметь права администратора.

  2. Нажмите "Next" (Далее).


Активизация DesignCenter Online (необязательная) [Руководство сетевого администратора AutoCAD: ]

Пользователи получают уведомления об обработке отчетов об ошибках
Использование Мастера развертывания
Активизация Центра подписки (необязательная)
Активизация DesignCenter Online (необязательная)

Вкладка DC Online в DesignCenter™ предоставляет доступ к предварительно созданных элементам, например блокам, библиотекам компонентов, библиотекам производителей и каталогам в Интернет. Эти элементы могут использоваться в совместном проектировании, что повышает эффективность процесса создания чертежей. При отключении DC Online его вкладка удаляется из всех установок, осуществляемых из данной папки развертывания. По умолчанию Интернет-модуль отключен.

ЗамечаниеВключить или отключить Design Center Online можно в Диспетчере интернет-компонентов, доступ к которому выполняется на вкладке "Установка" (при развертывании отдельной версии на несколько рабочих мест или сетевом развертывании) обозревателя диска.

Включение и отключение Design Center Online

  1. На странице "DC Online" Мастера развертывания выполните одно из следующих действий:
    • Для отключения модуля установите флажок "Отключить DesignCenter Online".
    • Для активизации модуля снимите флажок "Отключить DesignCenter Online".

  2. Нажмите "Далее".


Активизация Центра подписки (необязательная) [Руководство сетевого администратора AutoCAD: ]

Активизация DesignCenter Online (необязательная)
Использование Мастера развертывания
Регистрация
Активизация Центра подписки (необязательная)

Центр подписки предоставляет подписчикам доступ к различным ресурсам, например к материалам e-Learning (интерактивным урокам с индивидуально определяемыми сроками) и службе веб-поддержки (в которую пользователи могут в интерактивном режиме направлять технические вопросы, адресованные специалистам по поддержке Autodesk).

Чтобы определить, будут ли пользователи, имеющие право на использование ресурсов, предоставляемых по подписке, иметь к ним доступ, необходимо выбрать "Справка", а затем "Ресурсы подписки" (пользователи, не имеющие такого доступа, все равно могут узнать о ресурсах подписки, используя тот же элемент в меню "Справка").

ЗамечаниеВключить или отключить Центр подписки можно в Диспетчере интернет-компонентов, доступ к которому выполняется на вкладке "Установка" (при развертывании отдельной версии на несколько рабочих мест или сетевом развертывании) обозревателя диска.

Чтобы включить или отключить доступ к центру подписки

  1. На странице "Доступ к центру подписки" Мастера развертывания установите или снимите флажок "Разрешить доступ к центру подписки из продукта Autodesk (рекомендуется)". Данная опция используется по умолчанию.

  2. Нажмите "Далее".

Если был выбран вариант установки с локальной лицензией, появляется страница "Регистрация". В противном случае появляется страница "Подтверждение".


Регистрация [Руководство сетевого администратора AutoCAD: ]

Активизация Центра подписки (необязательная)
Использование Мастера развертывания
Подтверждение и завершение настройки
Регистрация

Если был выбран вариант автономной установки (или автономной установки на нескольких пользователей), появится страница "Регистрация". На этом этапе нужно заполнить регистрационную форму таким образом, чтобы все пользователи имели одинаковые регистрационные данные.

Для выполнения регистрации необходимо следовать инструкциям Мастера регистрации. После завершения регистрации выполняется переход на страницу "Подтверждение".


Подтверждение и завершение настройки [Руководство сетевого администратора AutoCAD: ]

Регистрация
Использование Мастера развертывания
Добавление программы Autodesk Vault 5 к папке развертывания (только для подписчиков)
Подтверждение и завершение настройки

Для завершения настройки развертывания необходимо подтвердить настройки, сделанные в Мастере развертывания.

Чтобы подтвердить и завершить настройку развертывания

  1. На странице "Подтверждение" Мастера развертывания подтвердите заданные установочные настройки.
  2. Если требуется изменить какие-либо из заданных настроек, нажмите кнопку "Назад".
  3. Для завершения настройки папки развертывания нажмите кнопку "Далее".

    ЗамечаниеМожно сохранить информацию с данной страницы, выделив текст, скопировав его в буфер обмена и вставив затем в текстовый файл (например в Блокноте Windows). Созданный файл рекомендуется сохранить в той же папке и под тем же именем, что было выбрано для папки развертывания. Так следует поступать, например, в случае, если необходимо иметь информацию обо всех настройках папки развертывания.
  4. Нажмите кнопку "Готово" на странице "Установка завершена".

Поздравляем! Итак, в результате выполненных действий создана папка развертывания для продукта Autodesk с настройками, соответствующими нуждам конкретной группы пользователей. Теперь можно оповестить пользователей о расположении созданного главного установочного образа, для того чтобы они могли установить из него программу.


Добавление программы Autodesk Vault 5 к папке развертывания (только для подписчиков) [Руководство сетевого администратора AutoCAD: ]

Подтверждение и завершение настройки
Развертывание программы
Представление главного установочного образа
Добавление программы Autodesk Vault 5 к папке развертывания (только для подписчиков)

После создания папки развертывания как описано в Использование Мастера развертывания, в установочный образ, распространяемый среди пользователей, можно добавить программу Autodesk® Vault 5. Для доступа к программе Autodesk Vault 5 и ее распространения необходимо иметь подписку. Подробнее о программе Autodesk Vault 5 и других средствах Vault см. "Интеграция Vault" в Руководстве пользователя.

ЗамечаниеПеред добавлением Autodesk Vault 5 к развертыванию AutoCAD 2007 запишите имя развертывания, которое планируется изменить, и путь к папке установочного образа.

Далее приводится рекомендованная процедура добавления Autodesk Vault 5 к развертыванию.

Добавление программы Autodesk Vault 5 к развертыванию (только для подписчиков)

  1. Войдите в Центр подписки Autodesk по адресу:

    http://www.autodesk.com/subscriptionlogin

  2. На первой странице Центра подписки в разделе Autodesk® Vault нажмите ссылку для запуска загрузки программы. Выполняйте экранные инструкции.
  3. В ответ на запрос сохраните файлы программы Vault 5 в папку установочного образа.

    \\<имя сервера>\<имя общего ресурса>\<папка установочного образа>\

    Например:

    \\Server1\Autodesk\AdminImage\

  4. В папке установочного образа найдите файл с расширением INI (имя файла совпадает с именем развертывания, созданного с помощью Мастера развертывания):

    Например:

    \\Server1\Autodesk\AdminImage\Deployment.ini\

  5. Сохраните резервную копию файла INI, если требуется просмотреть исходный файл или вернуться к нему.
  6. Откройте файл INI в текстовом редакторе, например NotePad.
  7. В этом текстовом файле, вставьте пробел и слово VAULT в конце списка SETUP_PRODUCT_NAMES (см. следующий пример):
    SETUP_PRODUCT_NAMES=MSI DOTNET DOTNETLANG DIRECTX MDAC VIEWER FLASH ACAD VAULT
  8. Добавьте следующие строки к коду настройки в конце файла INI (измените путь к INSTALL_CMD, если необходимо):
    [VAULT]
    PRODUCT_NAME=Vault
    INSTALL_CMD=\\<имя сервера>\<имя общего ресурса>\AdminImage\VE\bin\acadfeui\Vault\Client\setup.exe
    INSTALL_CMD_ARGS=VAULTROOTDIR="c:\Program Files" VAULTSHOWS=1 passive=yes
    INSTALL_IGNORE_FAILURE=NO
  9. (Дополнительно) Выполните одно из следующих действий:
    • Чтобы не помещать ярлык программы Autodesk Vault 5 на рабочий стол, измените VAULTSHOWS=1 на VAULTSHOWS=0.
    • Для установки Vault с минимальным количеством диалоговых окон измените passive=yes на quiet=yes.
  10. Сохраните файл INI.

    Теперь программу Autodesk Vault 5 можно распространять в составе развертывания.

ЗамечаниеПроцесс установки программы Vault может прерваться, если запущены некоторые приложения (например Microsoft® Outlook® или антивирусная программа). Во избежание потери данных перед установкой развертывания следует закрыть все запущенные на компьютерах пользователей приложения.


Представление главного установочного образа [Руководство сетевого администратора AutoCAD: ]

Добавление программы Autodesk Vault 5 к папке развертывания (только для подписчиков)
Развертывание программы
Удаление программы
Представление главного установочного образа

После завершения работы Мастера развертывания пользователи могут установить программу из только что созданной или отредактированной папки развертывания. Администратор должен предоставить главный установочный образ пользователям, оповестив их о наличии ярлыка для установки. Имя ярлыка совпадает с указанным при создании развертывания. Подробнее о задании имен см. Создание и редактирование папки развертывания.

Для представления главного установочного образа пользователям

  • Самый простой способ уведомления пользователей об установке программы из папки развертывания - это отправка письма по электронной почте с разъяснениями, как запустить процесс установки с помощью ярлыка. Письмо, как минимум, должно содержать информацию о пути к папке развертывания и необходимости двойного нажатия на ярлыке для запуска установки.
ЗамечаниеПодробнее о способах запуска развертывания с помощью ярлыка см. Анонсирование развертывания при помощи Microsoft Installer (MSI), Использование сценариев для развертывания программы, Использование групповой политики для установки из папки развертывания, Использование Microsoft Systems Management Server для установки развертывания и Использование Microsoft Systems Management Server для установки развертывания .


Удаление программы [Руководство сетевого администратора AutoCAD: ]

Представление главного установочного образа
Развертывание программы
Анонсирование развертывания при помощи Microsoft Installer (MSI)
Удаление программы

При удалении AutoCAD 2007 удаляются все установленные компоненты. Это происходит даже в том случае, если при предыдущем вызове программы установки производилось добавление или удаление компонентов, переустановка или восстановление программы. Из системы удаляются все файлы программы.

ЗамечаниеЕсли в дальнейшем планируется редактировать главный установочный образ (например добавить к нему файл обновления), этот образ удалять не следует.

Чтобы удалить программу

  1. В Панели управления Windows нажмите кнопку мыши на элементе "Установка и удаление программ".
  2. В диалоговом окне "Установка и удаление программ" выберите AutoCAD 2007 и нажмите "Удалить".
  3. В появившемся окне сообщения нажмите кнопку "Да" для удаления программы.
  4. Если потребуется, перезагрузите компьютер.
ЗамечаниеПрограммы Autodesk, используемые вместе с этой программой (например Autodesk DWF Viewer), при удалении AutoCAD не удаляются автоматически. Их необходимо удалить отдельно с помощью окна "Установки и удаления программ".


Анонсирование развертывания при помощи Microsoft Installer (MSI) [Руководство сетевого администратора AutoCAD: ]

Удаление программы
Анонсирование
Анонсирование развертывания при помощи Microsoft Installer (MSI)

Анонсирование - это способ развертывания, использующийся для предоставления доступа к развернутому в сети приложению с целью его последующей установки на рабочую станцию. Администратор создает на общем сетевом ресурсе главный установочный образ, а затем на каждой рабочей станции создает ярлык для этой программы. При нажатии на ярлык этой программы запускается установка продукта.

Для обеспечения успешной работы AutoCAD на том компьютере, на котором устанавливается эта программа, необходимо установить следующее программное обеспечение:

  • Microsoft .NET 2.0 (находится на установочном диске программы)
  • Microsoft Internet Explorer версии 6.0 с пакетом обновления 1 или более поздней версии (можно загрузить Microsoft Internet Explorer с веб-узла корпорации Майкрософт www.microsoft.com).
  • Microsoft Installer Package (MSI) 3.1
  • Macromedia Flash™ Player 8.0.22.0
  • Autodesk DWF Viewer® 6.5
  • Microsoft Data Access Components (MDAC) 2.7 с пакетом обновления SP 1

Темы в этом разделе

  • Анонсирование


Анонсирование [Руководство сетевого администратора AutoCAD: ]

Анонсирование развертывания при помощи Microsoft Installer (MSI)
Анонсирование развертывания при помощи Microsoft Installer (MSI)
Использование сценариев для развертывания программы
Анонсирование

После создания в общей сетевой папке главного установочного образа нужно настроить ярлык для запуска программы пользователями. Имя программы добавляется в меню "Пуск" Windows и в список "Установка/удаление программ".

Анонсирование развертывания с помощью MSI 3.1

  1. На рабочей станции пользователя в меню "Пуск" (Windows) выберите "Все программы" (или "Программы") [image] "Стандартые" [image] "Командная строка".
  2. В командной строке Windows для настройки ярлыка введите:

    msiexec /jm \\[имя сервера]\[имя общего ресурса]\AdminImage\acad.msi /t \\[имя сервера]\[имя общего ресурса]\AdminImage\[имя развертывания].mst

Эта программа анонсирована. Для установки этой программы на рабочую станцию пользователь должен выбрать ярлык программы в меню "Пуск" системы Windows. Это самый быстрый способ анонсирования этой программы, требующий минимального вмешательства пользователя.


Использование сценариев для развертывания программы [Руководство сетевого администратора AutoCAD: ]

Анонсирование
Введение
Использование сценариев для развертывания программы

Сценарий выполняет команду или набор команд. Сценарии во многом сходны с командными файлами, но являются более гибкими. Сценарии установки лучше всего использовать при автономной установке программ на подключенные к сети компьютеры. Их также применяют для установки пакетов обновления, расширений и адаптеров объектов в сети.

Для обеспечения успешной работы AutoCAD на том компьютере, на котором устанавливается эта программа, необходимо установить следующее программное обеспечение:

  • Microsoft .NET 2.0 (находится на установочном диске программы)
  • Microsoft Internet Explorer версии 6.0 с пакетом обновления 1 или более поздней версии (можно загрузить Microsoft Internet Explorer с веб-узла корпорации Майкрософт www.microsoft.com).
  • Microsoft Installer Package (MSI) 3.1
  • VB Script
  • Macromedia Flash™ Player 8.0.22.0
  • Autodesk DWF Viewer® 6.5
  • Microsoft Data Access Components (MDAC) 2.7 с пакетом обновления SP 1

Темы в этом разделе

  • Введение
  • Создание сценариев установки продукта
  • Пример сценария установки
  • Управляющие параметры в сценариях
  • Флаги задания пользовательского интерфейса в сценариях
  • Сценарии выборочной установки
  • Запуск сценариев
  • Примеры сценариев


Введение [Руководство сетевого администратора AutoCAD: ]

Использование сценариев для развертывания программы
Использование сценариев для развертывания программы
Создание сценариев установки продукта
Введение

С помощью технологии Microsoft Windows® Installer (MSI) можно использовать сценарии для установки программ без вмешательства пользователя (пользователь должен только запустить сценарий).

Системные требования для сценариев на Visual Basic® Scripting Edition (VBS Scripts):

  • Microsoft Windows Installer версии 3.1 или выше
  • Microsoft Scripting Engine
  • Права администратора (на всех компьютерах с установленной операционной системой Windows® XP Professional, Windows XP Home и Windows 2000).

Microsoft Windows Installer - это программа для установки и настройки, которая устанавливается на компьютере при установке этой программы. Программа включена в ОС Windows XP Professional, Windows XP Home и Windows 2000. Более подробную информацию о технологии MSI можно найти на сайте Microsoft.

ЗамечаниеДля установки этой программы необходим использовать Windows Installer (WindowsInstaller-KB893803-v2-x86.exe) версии 3.1 или выше. Если установлена более ранняя версия, можно установить более новую версию с компакт-диска продукта. Найти папку MSI на установочном диске и запустить файл WindowsInstaller-KB893803-v2-x86.exe.

Примеры сценариев, которые можно найти в данном приложении, созданы в Microsoft Scripting Engine 5.6, работающем как с JavaScript, так и с VBS-сценариями. Если обработчик сценариев не установлен, его можно бесплатно загрузить с веб-сайта компании Microsoft по адресу www.msdn.microsoft.com/scripting. Здесь также доступны для загрузки примеры сценариев и файлы справки.


Создание сценариев установки продукта [Руководство сетевого администратора AutoCAD: ]

Введение
Использование сценариев для развертывания программы
Пример сценария установки
Создание сценариев установки продукта

Сценарий создается в текстовом редакторе (например в Блокноте Windows), а затем сохраняется в формате ASCII в файле с расширением .vbs. Сценарий может состоять из одной или нескольких команд, а также параметров, задающих определенные опции, и флагов, изменяющих эти опции. Сценарий установки также содержит имена путей.

Сценарий установки указывает местоположение файла программы setup.exe. Необходимо выбрать файл setup.exe на компакт-диске. Например:

AutoCAD 2007 CDROM\Bin\ACADFeui\setup.exe


Пример сценария установки [Руководство сетевого администратора AutoCAD: ]

Создание сценариев установки продукта
Использование сценариев для развертывания программы
Управляющие параметры в сценариях
Пример сценария установки

В примере сценария автоматической установки этой программы используется синтаксис, описанный в данном разделе. Этот же сценарий можно найти в разделе "Примеры сценариев" (Пример сценария № 1).

' Типовая установка AutoCAD 2007

' Создание переменных

dim strADSKFirstName

strADSKFirstName = "Ваше имя"

dim strADSKLastName

strADSKLastName = "Ваша фамилия"

dim strDealer

strDealer = "Продавец"

dim strDealerPhone

strDealerPhone = "411"

' Переменная, в которой хранится имя дилера.

dim strADSKCompany

strADSKCompany = "Название компании"

' Создание переменных для хранения серийного номера

Dim strADSKSNPrefix

strADSKSNPrefix = "123"

dim strADSKSNNumber

strADSKSNNumber = "12345678"

Set shell = CreateObject("WScript.Shell")

' Переменная, в которой хранится путь к папке для установки (с длинным именем файла).

Dim strProgPath

strProgPath = Shell.ExpandEnvironmentStrings("%ProgramFiles%")

dim strADSKPath

strADSKPath = strProgPath + "\AutoCAD 2007"

' Создание переменной для хранения исходного пути AutoCAD 2007

Dim strSourcePath

' Где D: соответствует компакт-диску продукта

strSourcePath = "D:\Bin\acadFeui"

'

' /q для автоматической установки, ' /c [key] - замена параметров ключа

shell.run strSourcePath & "\setup.exe /q /c acad:" & """" & _

"INSTALLDIR=\"& """" & strADSKPath & "\" & """" & "" &_

"REBOOT=Suppress /qb!" & " " & _

"ACAD_SILENT_LICENSE=YES" & " " & _

"ACADSERIALPREFIX=" & strADSKSNPrefix & " " & _

"ACADSERIALNUMBER=" & strADSKSNNumber & " " & _

"ACADFIRSTNAME=\" & """"& strADSKFirstName & "\" & """" & " " & _

"ACADLASTNAME=\" & """"& strADSKLastName & "\" & """" & " " & _

"ACADDEALER=\" & """"& strDealer & "\" & """" & " " & _

"ACADDEALERPHONE=\" & """"& strDealerPhone & "\" & """" & " " & _

"ACADORGANIZATION=\" & """" & strADSKCompany & "\" & """" & " " & _

"INSTALLLEVEL=3

" & """"


Управляющие параметры в сценариях [Руководство сетевого администратора AutoCAD: ]

Пример сценария установки
Использование сценариев для развертывания программы
Флаги задания пользовательского интерфейса в сценариях
Управляющие параметры в сценариях

В приведенной ниже таблице представлен список всех управляющих параметров, используемых при установке.

Замечание Параметр установки INSTALLDIR= обязателен. Иначе программы, запускаемые извне (не из AutoCAD), такие как утилита перемещения лицензий, не установятся.
Параметры в сценариях установки
Параметр | Описание
INSTALLDIR= | Папка для установки продукта.
ACAD_SILENT_LICENSE=YES | Задание недиалогового режима установки.
ACADSERIALPREFIX= | Начальный фрагмент серийного номера (префикс).
ACADSERIALNUMBER= | Серийный номер.
ACADLASTNAME= | Вариант установки: 3=типовая
ACADFIRSTNAME= | Имя для ввода в персональные данные.
ACADLASTNAME= | Фамилия для ввода в персональные данные.
ACADORGANIZATION= | Название организации.
ACADDEALER= | Дилер.
ACADDEALERPHONE= | Телефон дилера.


Флаги задания пользовательского интерфейса в сценариях [Руководство сетевого администратора AutoCAD: ]

Управляющие параметры в сценариях
Использование сценариев для развертывания программы
Сценарии выборочной установки
Флаги задания пользовательского интерфейса в сценариях

С помощью флагов, приведенных в следующей таблице, можно задать пользовательский интерфейс, отображаемый во время установки.

Флаги пользовательского интерфейса
Флаг | Описание
q или qn | Интерфейс пользователя отсутствует.
qn+ | Пользовательский интерфейс отсутствует, за исключением диалогового окна, открывающегося в конце установки.
qb | Базовый пользовательский интерфейс.
qb+ | Базовый пользовательский интерфейс с диалоговым окном в конце установки. (Диалоговое окно не отображается, если пользователь отменяет установку.)
qb- | Базовый пользовательский интерфейс без диалоговых окон.
qf | Полный пользовательский интерфейс с диалоговым окном в конце установки.
qr | Сокращенный пользовательский интерфейс с диалоговым окном в конце установки.


Сценарии выборочной установки [Руководство сетевого администратора AutoCAD: ]

Флаги задания пользовательского интерфейса в сценариях
Использование сценариев для развертывания программы
Запуск сценариев
Сценарии выборочной установки

Чтобы создать сценарий для выборочной установки, используйте синтаксис: ADDLOCAL=".....". См. Пример сценария 2: выборочная установка.

Флаги компонентов
Флаг | Компонент
ACS | Примеры
CADStandards | Стандарты оформления
Database | База данных (DBCONNECT)
DCS | Примеры для DesignCenter
Dictionaries | Словари
DrawingEncryption | Шифрование чертежей
Express_Tools | Дополнительные утилиты Express Tools
Fonts | Шрифты
Materials | Библиотека материалов
Migrate | Перенос пользовательских настроек
NFW | Семинар по новым возможностям
PLM | Утилита перемещения лицензий
RefMan | Диспетчер ссылок
Samples | Файлы примеров
System_Files | Необходимые системные файлы
TM | Текстуры
Tutorials | Учебные пособия
VBA | Visual Basic
VLS | Примеры Visual LISP
VLT | Учебные пособия по Visual LISP


Запуск сценариев [Руководство сетевого администратора AutoCAD: ]

Сценарии выборочной установки
Использование сценариев для развертывания программы
Примеры сценариев
Запуск сценариев

После создания сценария переместите его на сервер или используйте обозначение сетевого диска или UNC-путь (универсальное соглашение об именовании). В случае расположения сценария на сервере для запуска пользователями создайте совместно используемый ресурс на сервере и добавьте пользователей с необходимыми правами доступа к этому ресурсу. Так как все, что нужно таким пользователям, это запустить сценарий, установите у каталога совместного ресурса параметр "Только для чтения".

Затем (на том же или на другом сервере) создайте папку для каждой устанавливаемой программы. Выберите неизменяемое местоположение папки, чтобы указать на файлы MSI в сценариях. Скопируйте установочные диски программ в эту папку. Возможно, возникнет желание создать директории для пакетов обновления, приложений и своих собственных средств адаптации.

Для запуска сценария установки можно использовать любой из описанных ниже способов.

  • Запустите сценарий вручную на каждой рабочей станции. Для запуска установки вставьте сценарий в диалоговое окно "Запуск" или запустите его из командной строки Windows.
  • Передайте по электронной почте каждому пользователю, который должен запустить сценарий, сообщение с указанием пути в формате UNC. Для запуска сценария пользователь выполняет инструкции.
  • Передайте по электронной почте каждому пользователю сообщение с инструкциями.
  • Настройте сценарий так, чтобы он запускался при регистрации пользователя.


Примеры сценариев [Руководство сетевого администратора AutoCAD: ]

Запуск сценариев
Использование сценариев для развертывания программы
Пример сценария 1: типовая установка
Примеры сценариев

Примеры сценариев, приведенные в данном разделе, позволяют выполнить установку программы в различных конфигурациях. Можно скопировать примеры сценариев и заменить их содержимое своими данными. Для переменных используются одинаковые имена. Имя файла журнала определяется устанавливаемым продуктом. Имя файла журнала в сценарии можно оставить неизменным или заменить на другое.

Префикс серийного номера: 123

Серийный номер: 12345678

Имя: Ваше имя

Фамилия: Ваша фамилия

Имя дилера: Ваш дилер

Организация: название компании

В примере сценария автоматической установки этой программы используется синтаксис, описанный в данном разделе. Этот же сценарий можно найти в разделе "Примеры сценариев" (Пример сценария № 1).

Темы в этом разделе

  • Пример сценария 1: типовая установка
  • Пример сценария 2: выборочная установка


Пример сценария 1: типовая установка [Руководство сетевого администратора AutoCAD: ]

Примеры сценариев
Примеры сценариев
Пример сценария 2: выборочная установка
Пример сценария 1: типовая установка

' Типовая установка AutoCAD 2007

' Создание переменных

dim strADSKFirstName

strADSKFirstName = "Ваше имя"

dim strADSKLastName

strADSKLastName = "Ваша фамилия"

dim strDealer

strDealer = "Продавец"

dim strDealerPhone

strDealerPhone = "411"

' Переменная, в которой хранится имя дилера.

dim strADSKCompany

strADSKCompany = "Название компании"

' Создание переменных для хранения серийного номера

Dim strADSKSNPrefix

strADSKSNPrefix = "123"

dim strADSKSNNumber

strADSKSNNumber = "12345678"

Set shell = CreateObject("WScript.Shell")

' Переменная, в которой хранится путь к папке для установки (с длинным именем файла).

Dim strProgPath

strProgPath = Shell.ExpandEnvironmentStrings("%ProgramFiles%")

dim strADSKPath

strADSKPath = strProgPath + "\AutoCAD 2007"

' Создание переменной для хранения исходного пути AutoCAD 2007

Dim strSourcePath

' Где D: соответствует компакт-диску продукта

strSourcePath = "D:\Bin\acadFeui"

'

' /q для автоматической установки, ' /c [key] - замена параметров ключа

shell.run strSourcePath & "\setup.exe /q /c acad:" & """" & _

"INSTALLDIR=\"& """" & strADSKPath & "\" & """" & "" &_

"REBOOT=Suppress /qb!" & " " & _

"ACAD_SILENT_LICENSE=YES" & " " & _

"ACADSERIALPREFIX=" & strADSKSNPrefix & " " & _

"ACADSERIALNUMBER=" & strADSKSNNumber & " " & _

"ACADFIRSTNAME=\" & """"& strADSKFirstName & "\" & """" & " " & _

"ACADLASTNAME=\" & """"& strADSKLastName & "\" & """" & " " & _

"ACADDEALER=\" & """"& strDealer & "\" & """" & " " & _

"ACADDEALERPHONE=\" & """"& strDealerPhone & "\" & """" & " " & _

"ACADORGANIZATION=\" & """" & strADSKCompany & "\" & """" & " " & _

"INSTALLLEVEL=3" & """"


Пример сценария 2: выборочная установка [Руководство сетевого администратора AutoCAD: ]

Пример сценария 1: типовая установка
Примеры сценариев
Использование групповой политики для установки из папки развертывания
Пример сценария 2: выборочная установка

' Пользовательская установка AutoCAD 2007 системные файлы, файлы примеров и дополнительные утилиты Express Tools.

' Создание переменных

dim strADSKFirstName

strADSKFirstName = "Ваше имя"

dim strADSKLastName

strADSKLastName = "Ваша фамилия"

dim strDealer

strDealer = "Продавец"

dim strDealerPhone

strDealerPhone = "411"

' Переменная, в которой хранится имя дилера.

dim strADSKCompany

strADSKCompany = "Название компании"

' Создание переменных для хранения серийного номера

dim strADSKSNPrefix

strADSKSNPrefix = "123"

dim strADSKSNNumber

strADSKSNNumber = "12345678"

Set shell = CreateObject("WScript.Shell")

' Переменная, в которой хранится путь к папке для установки (с длинным именем файла).

Dim strProgPath

strProgPath = Shell.ExpandEnvironmentStrings("%ProgramFiles%")

dim strADSKPath

strADSKPath = strProgPath + "\AutoCAD 2007"

' Создание переменной для хранения исходного пути AutoCAD 2007

dim strSourcePath

' Где D: соответствует компакт-диску продукта

strSourcePath = "D:\Bin\acadFeui"

'

' /q для автоматической установки, ' /c [key] - замена параметров ключа

shell.run strSourcePath & "\setup.exe /q /c acad:" & """" & _

"INSTALLDIR=\" & """" & strADSKPath & "\" & """" & " " & _

"REBOOT=Suppress /qb!" & " " & _

"ACAD_SILENT_LICENSE=YES" & " " & _

"ACADSERIALPREFIX=" & strADSKSNPrefix & " " & _

"ACADSERIALNUMBER=" & strADSKSNNumber & " " & _

"ACADFIRSTNAME=\" & """"& strADSKFirstName & "\" & """" & " " & _

"ACADLASTNAME=\" & """"& strADSKLastName & "\" & """" & " " & _

"ACADDEALER=\" & """"& strDealer & "\" & """" & " " & _

"ACADDEALERPHONE=\" & """"& strDealerPhone & "\" & """" & " " & _

"ACADORGANIZATION=\" & """" & strADSKCompany & "\" & """" & "" & _

"ADDLOCAL=\" & """" & "System_Files,ACS,Express_Tools" & "\" & """"


Использование групповой политики для установки из папки развертывания [Руководство сетевого администратора AutoCAD: ]

Пример сценария 2: выборочная установка
Введение
Использование групповой политики для установки из папки развертывания

С помощью групповой политики можно анонсировать эту программу, назначая развертывание на компьютерах.

Для обеспечения успешной работы AutoCAD на том компьютере, на котором устанавливается эта программа, необходимо установить следующее программное обеспечение:

  • Microsoft .NET 2.0 (находится на установочном диске программы)
  • Microsoft Internet Explorer версии 6.0 с пакетом обновления 1 или более поздней версии (можно загрузить Microsoft Internet Explorer с веб-узла корпорации Майкрософт www.microsoft.com).
  • Microsoft Installer Package (MSI) 3.1
  • Macromedia Flash™ Player 8.0.22.0
  • Autodesk DWF Viewer® 6.5
  • Microsoft Data Access Components (MDAC) 2.7 с пакетом обновления SP 1

Темы в этом разделе

  • Введение
  • Распространение развертывания с помощью групповой политики
  • Назначение развертывания компьютерам
  • Подтверждение установки программы из папки развертывания


Введение [Руководство сетевого администратора AutoCAD: ]

Использование групповой политики для установки из папки развертывания
Использование групповой политики для установки из папки развертывания
Назначение развертывания с помощью групповой политики
Введение

С помощью объектов групповой политики эту программу можно анонсировать на любом компьютере, который входит в среду Active Directory систем Windows 2000 и Windows 2003.

Темы в этом разделе

  • Назначение развертывания с помощью групповой политики
  • Преимущества и недостатки групповой политики


Назначение развертывания с помощью групповой политики [Руководство сетевого администратора AutoCAD: ]

Введение
Введение
Преимущества и недостатки групповой политики
Назначение развертывания с помощью групповой политики

Назначает для компьютера развертывание, созданное "Мастером развертывания". Назначение развертывания позволяет установить программу на компьютер пользователя при следующем запуске компьютера.

Развертывание, назначенное компьютеру, доступно всем пользователям этого компьютера. Как правило, программу необходимо назначать компьютеру, если на нем работает большое количество пользователей.

ЗамечаниеУстановка продуктов Autodesk разработана таким образом, что любой пользователь, который входит в систему, может запустить программу. При попытке назначить программу определенному пользователю, а не компьютеру, возможно, возникнут проблемы, когда другой пользователь данного компьютера попытается установить или удалить копию этой программы.


Преимущества и недостатки групповой политики [Руководство сетевого администратора AutoCAD: ]

Назначение развертывания с помощью групповой политики
Введение
Распространение развертывания с помощью групповой политики
Преимущества и недостатки групповой политики

В приведенной ниже таблице выделены преимущества и недостатки использования групповой политики.

Преимущества и недостатки групповой политики

Преимущества

Недостатки

Совместима с мастером развертывания.

Нельзя передать параметры командной строки в исполняемый MSI-файл. Решение проблемы - в использовании сценариев.
  • Можно добавлять пользовательские файлы с помощью мастера развертывания.
  • Развертывается на рабочую станцию.

Нельзя адаптировать настройки приложения, кроме тех, что заданы в мастере развертывания.

Легко использовать.


Распространение развертывания с помощью групповой политики [Руководство сетевого администратора AutoCAD: ]

Преимущества и недостатки групповой политики
Использование групповой политики для установки из папки развертывания
Назначение развертывания компьютерам
Распространение развертывания с помощью групповой политики

Для распространения программы с помощью групповой политики необходимо выполнить три шага.

  1. Задание пункта распространения приложения. Пункт распространения приложения создан с помощью Мастера развертывания. В разделе Использование Мастера развертывания приведены инструкции по выполнению развертывания.
  2. Назначение программы компьютеру.
  3. Подтверждение установки. Убедитесь, что программа установлена правильно.


Назначение развертывания компьютерам [Руководство сетевого администратора AutoCAD: ]

Распространение развертывания с помощью групповой политики
Использование групповой политики для установки из папки развертывания
Подтверждение установки программы из папки развертывания
Назначение развертывания компьютерам

Когда программа назначается для компьютера, то она становится доступной для всех пользователей этого компьютера. Чтобы выполнить назначение программы для компьютеров, на сервере, который имеет доступ к среде Active Directory в системе Windows 2003 или Windows 2000, следует выполнить описанные ниже действия.

Для назначения развертывания компьютеру

  1. В меню "Пуск" (Windows) выбрать "Все программы" (или "Программы") [image] "Администрирование" [image] "Active Directory: пользователи и компьютеры".
  2. В окне "Active Directory: пользователи и компьютеры" нажмите правой кнопкой мыши на организационном подразделении, для которого нужно создать объект групповой политики. Затем выберите команду "Свойства".

    Открывается диалоговое окно "Свойства" для выбранного организационного подразделения.

    ЗамечаниеДля того чтобы параметры создаваемого объекта групповой политики вступили в силу, необходимо, чтобы объекты-компьютеры принадлежали к выбранному сайту, домену или подразделению.
  3. На вкладке "Групповая политика" диалогового окна "Свойства" нажмите кнопку "Создать". Введите имя объекта групповой политики. Например, введите AutoCAD Computer Assigned Installation.

    Создается новый объект групповой политики, который добавляется в список "Ссылки на объекты групповой политики".

  4. В списке записей в окне "Ссылки на объекты групповой политики" выберите созданный объект групповой политики и нажать кнопку "Изменить".
  5. Выполните одно из следующих действий:
    • Для Windows 2003 Server. В окне "Редактирование объектов групповой политики" на вкладке "Конфигурация компьютера" нажмите на значок "плюс" (+) слева от папки Конфигурация программ для раскрытия списка.
    • Для Windows 2000 Server: В окне "Групповая политика" на вкладке "Конфигурация компьютера" нажмите на значок "плюс" (+) слева от папки Конфигурация программ для раскрытия списка.
  6. В разделе "Конфигурация программ" нажмите правой кнопкой на вкладку "Установка программ", а затем выберите "Свойства".
  7. В диалоговом окне "Свойства: установка программ" на вкладке "Общие" нажмите "Обзор".
  8. В диалоговом окне "Обзор папок" перейдите к пункту распространения приложения, созданному с помощью Мастера развертывания, и выберите папку AdminImage. Затем нажмите "OK".

    В диалоговом окне "Свойства: Установка программ" отображаются заданный по умолчанию путь к программному пакету (в UNC-формате), имя сервера, выбранная сетевая папка и папка AdminImage. Например:

    \\server123\Deployment\AdminImage

  9. Выполните одно из следующих действий:
    • Для Windows 2003 Server. На вкладке "Общие" в разделе "Новые пакеты" выберите параметр "Дополнительно" для выбора способа, используемого при создании нового пакета. Этот способ позволяет также выбрать файл преобразования, созданный мастером развертывания.
    • Для Windows 2000 Server: На вкладке "Общие" в разделе "Новые пакеты" выберите параметр "Разрешать расширенную публикацию/назначение" для выбора способа, используемого при создании нового пакета. Этот способ позволяет также выбрать файл преобразования, созданный мастером развертывания.
  10. Нажмите "OK", чтобы закрыть диалоговое окно "Свойства: Установка программ".
  11. Выполните одно из следующих действий:
    • Для Windows 2003 Server: в диалоговом окне "Редактор объектов групповой политики" в области "Параметры программ" нажмите правую кнопку мыши на "Установка программы" и выберите "Создать" [image] "Комплект".
    • Для Windows 2000 Server: В диалоговом окне "Групповая политика" в области "Параметры программ" нажмите правую кнопку мыши на "Установка программы" и выберите "Создать" [image] "Комплект".
  12. В диалоговом окне "Открыть" убедитесь, что выбран файл пакетов Windows Installer (acad.msi) и нажмите кнопку "Открыть". Диалоговое окно "Открыть" показывает те пакеты, которые расположены в пункте распространения программного обеспечения, выбранном по умолчанию.

    Если главный установочный образ был создан не в пункте распространения программного обеспечения, нужно найти его файлы и выбрать среди них файл acad.msi.

  13. В диалоговом окне "Свойства: <имя продукта>" перейдите на вкладку "Развертывание". Убедитесь, что в группе "Тип развертывания" выбран параметр "Назначенный".
  14. На вкладке "Модификации" нажмите кнопку "Добавить".
  15. В диалоговом окне "Открыть" выберите файл преобразования (файл с расширением MST), созданный Мастером развертывания. Затем нажмите кнопку "Открыть".

    Если главный установочный образ был создан не в пункте распространения программного обеспечения, нужно найти его файлы и выбрать среди них файл преобразования (файл с расширением .mst).

  16. В диалоговом окне "Свойства: <product name>" на вкладке "Модификации" выбранный файл преобразования добавляется к списку "Модификации". Нажмите "ОК".
    ЗамечаниеЕсли создан объект групповой политики, необходимо выбрать файл преобразования, созданный Мастером развертывания. После создания объекта групповой политики добавить или удалить пакетные файлы преобразований невозможно. Если не выбрать файл преобразования, программу не удастся установить на клиент-компьютере.
  17. Выполните одно из следующих действий:
    • Для Windows 2003 Server. В окне "Редактирование объектов групповой политики" на вкладке "Конфигурация компьютера" нажмите "Установка программ". Только что созданный пакет программы отобразится в правой области окна.
    • Для Windows 2000 Server: в окне "Групповая политика" на вкладке "Конфигурация компьютера" нажмите "Установка программ". Только что созданный пакет программы отобразится в правой области окна.
  18. Выполните одно из следующих действий:
    • Для Windows 2003 Server: закройте окно "Редактирование объектов групповой политики" и все окна, относящиеся к "Active Directory".
    • Для Windows 2000 Server: закройте окно "Групповая политика" и все окна, относящиеся к "Active Directory".

Эта программа назначается для всех компьютеров, входящих в состав организационного подразделения, для которого был создан объект групповой политики. При следующем запуске компьютера программа будет установлена и доступна для всех пользователей этого компьютера. О подтверждении правильности создания объекта групповой политики см. Подтверждение установки программы из папки развертывания.


Подтверждение установки программы из папки развертывания [Руководство сетевого администратора AutoCAD: ]

Назначение развертывания компьютерам
Использование групповой политики для установки из папки развертывания
Проверка назначения программы для компьютера
Подтверждение установки программы из папки развертывания

После перезагрузки компьютера выводятся сообщения операционной системы о групповой политике - обычно они появляются до диалогового окна 'Вход в Windows' или сразу после него. Выводятся сообщения о следующих процессах:

  • Запуск Windows.
  • Применение параметров компьютера
  • Установка программы <приложения>
  • Применение параметров установки программного обеспечения
  • Загрузка личных параметров
  • Применение личных параметров

Пользователи рабочих станций, работающих в Windows XP или Windows 2000, регистрируются в организационном подразделении или на компьютере, для которого была создана групповая политика.

ЗамечаниеПри возникновении проблем в средстве просмотра событий в разделе "Приложения" регистрируются соответствующая запись.

Темы в этом разделе

  • Проверка назначения программы для компьютера


Проверка назначения программы для компьютера [Руководство сетевого администратора AutoCAD: ]

Подтверждение установки программы из папки развертывания
Подтверждение установки программы из папки развертывания
Использование Microsoft Systems Management Server для установки развертывания
Проверка назначения программы для компьютера

Для того чтобы убедиться, что эта программа правильно назначена для компьютера, нужно перезапустить компьютер, входящий в состав организационного подразделения, для которой была создана групповая политика. Программа устанавливается до отображения приглашения на вход в систему. После входа в систему дважды нажмите кнопку мыши на ярлыке программы на рабочем столе. Начнется процесс вторичной установки. Программа запустится после завершения установки.


Использование Microsoft Systems Management Server для установки развертывания [Руководство сетевого администратора AutoCAD: ]

Проверка назначения программы для компьютера
Введение
Использование Microsoft Systems Management Server для установки развертывания

Данное приложение предоставляет информацию по развертыванию программных продуктов Autodesk с помощью системы управления сетями Microsoft Systems Management Server (в дальнейшем SMS). Преимуществом использования SMS для сетевого развертывания продуктов является возможность динамического тестирования компьютеров, на которые предполагается установить продукт. Аппаратные средства и программное обеспечение выбранных компьютеров проверяются на предмет соответствия требованиям установки.

Для обеспечения успешной работы AutoCAD на тот компьютер, на который устанавливается данная программа, необходимо установить следующее программное обеспечение:

  • Microsoft .NET 2.0 (находится на установочном диске программы)
  • Microsoft Internet Explorer версии 6.0 с пакетом обновления 1 или более поздней версии (можно загрузить Microsoft Internet Explorer с веб-узла корпорации Майкрософт www.microsoft.com).
  • Microsoft Installer Package (MSI) 3.1
  • Macromedia Flash™ Player 8.0.22.0
  • Autodesk DWF Viewer® 6.5
  • Microsoft Data Access Components (MDAC) 2.7 с пакетом обновления SP 1

Темы в этом разделе

  • Введение
  • Подготовка к развертыванию продуктов Autodesk с помощью SMS
  • Создание коллекции для распространения программного обеспечения Autodesk
  • Настройка исходной папки с помощью Мастера развертывания
  • Создание SMS-пакета установки программного обеспечения
  • Создание SMS-программы
  • Создание анонсирования
  • Установка продуктов Autodesk на клиент-компьютере


Введение [Руководство сетевого администратора AutoCAD: ]

Использование Microsoft Systems Management Server для установки развертывания
Использование Microsoft Systems Management Server для установки развертывания
Подготовка к развертыванию продуктов Autodesk с помощью SMS
Введение

Для развертывания программ Autodesk® необходим SMS 2.0 с пакетом обновления SP 1 или более поздней версии. Необходимо также знать с процедуру распространения программного обеспечения SMS 2.0. Дополнительные сведения по данной теме можно найти в следующих источниках:

  • Microsoft ® Systems Management Server, руководство по администрированию
  • Справка Microsoft Systems Management Server 2.0 Administrator
  • Справочник администратора Microsoft Systems Management Server
  • Руководство по ресурсам Microsoft Systems Management Server


Подготовка к развертыванию продуктов Autodesk с помощью SMS [Руководство сетевого администратора AutoCAD: ]

Введение
Использование Microsoft Systems Management Server для установки развертывания
Создание коллекции для распространения программного обеспечения Autodesk
Подготовка к развертыванию продуктов Autodesk с помощью SMS

Для развертывания продуктов Autodesk с помощью SMS необходимо выполнить следующие процедуры:

  1. Создание коллекции для распространения программного обеспечения Autodesk.
  2. Настройка исходной папки с помощью Мастера развертывания.
  3. Создание SMS-пакета установки программного обеспечения.
  4. Создание SMS-программы.
  5. Создание объявления.
  6. Установка программы Autodesk на клиент-компьютере.


Создание коллекции для распространения программного обеспечения Autodesk [Руководство сетевого администратора AutoCAD: ]

Подготовка к развертыванию продуктов Autodesk с помощью SMS
Использование Microsoft Systems Management Server для установки развертывания
Создание правила с помощью кнопки панели Query Rule Properties (Запрос критериев)
Создание коллекции для распространения программного обеспечения Autodesk

Коллекция - это совокупность задаваемых администратором правил, в которых определено, на какие компьютеры можно устанавливать программное обеспечение Autodesk. Для создания и сопровождения коллекций можно использовать SMS. В коллекциях ресурсы собираются в логические управляемые группы, что помогает при управлении узлом SMS. Коллекции могут отражать структуру и организацию сети при классификации ресурсов по группам, таким как пользователи, клиенты и маршрутизаторы. SMS использует коллекции в качестве целей при распространении клиентам программного обеспечения.

Чтобы создать коллекцию для распространения продуктов Autodesk

  1. В меню "Пуск" (Windows) выберите "Все программы" (или "Программы") [image] System Management Server [image] "Консоль администратора SMS".
  2. В окне консоли SMS выберите в области структуры папку Systems Management Server и нажмите значок "плюс" (+) слева от папки Site Database .
  3. В области структуры выберите папку Collections (Коллекции).

    Область Name (Имя) отображает список всех наборов правил, заданных в настоящее время.

  4. Нажмите правую кнопку мыши на папке Collections (Коллекции). Выберите в контекстном меню "Создать" [image] "Коллекция".
  5. На вкладке General (Общие) диалогового окна Collection Properties (Свойства коллекции) введите имя коллекции (набора правил), например Autodesk software computers. В поле Comment (Комментарии) введите необходимые комментарии.

Теперь нужно создать правила, на основании которых в набор будут включены ресурсы. Это можно сделать при помощи кнопки панели Query Rule Properties (Запрос критериев) или Мастера Direct Membership Rule (Правила прямого членства).

Темы в этом разделе

  • Создание правила с помощью кнопки панели Query Rule Properties (Запрос критериев)
  • Создание правила с помощью Мастера Direct Membership Rule (Правила прямого членства)


Создание правила с помощью кнопки панели Query Rule Properties (Запрос критериев) [Руководство сетевого администратора AutoCAD: ]

Создание коллекции для распространения программного обеспечения Autodesk
Создание коллекции для распространения программного обеспечения Autodesk
Создание правила с помощью Мастера Direct Membership Rule (Правила прямого членства)
Создание правила с помощью кнопки панели Query Rule Properties (Запрос критериев)

С помощью кнопки панели Query Rule Properties можно добавить в коллекцию все ресурсы, которые соответствуют критериям, заданным в запросе.

Для создания правила с помощью кнопки панели Query Rule Properties (Запрос критериев)

  1. На вкладке Membership Rules (Правила членства) диалогового окна Collection Properties (Свойства коллекции) нажмите кнопку панели Query Rule Properties (Запрос критериев).
  2. В диалоговом окне Query Rule Properties (Запрос критериев) нажмите кнопку Browse (Обзор) (рядом с полем Name).

    Выводится список доступных запросов.

  3. Выберите подходящий запрос. Начните с выбора All Windows Systems (Все системы Windows) и нажмите кнопку "ОК".

    В диалоговом окне Query Rule Properties (Запрос критериев) можно создать или изменить запрос, нажав кнопку Edit Query Statement (Редактирование запрашиваемых утверждений). В разделе Collection Limiting (Ограничения коллекции) можно ограничить число запросов, заданных для набора, нажав кнопку Limit to Collection (Ограничить для коллекции).

  4. Нажмите "ОК".

Созданное правило добавляется в список правил Rules (Правила) в диалоговом окне Collection Properties (Свойства коллекции).


Создание правила с помощью Мастера Direct Membership Rule (Правила прямого членства) [Руководство сетевого администратора AutoCAD: ]

Создание правила с помощью кнопки панели Query Rule Properties (Запрос критериев)
Создание коллекции для распространения программного обеспечения Autodesk
Настройка исходной папки с помощью Мастера развертывания
Создание правила с помощью Мастера Direct Membership Rule (Правила прямого членства)

С помощью мастера Direct Membership Rule можно создавать правила непосредственного членства для коллекции. В противоположность правилам членства в наборе, основанным на запросах, которые добавляют в группу все ресурсы, соответствующие заданным критериям отбора, правила непосредственного членства в наборе добавляют в набор только выбранные администратором ресурсы. Для создания правил непосредственного членства в наборе нужно самостоятельно выбрать ресурсы для добавления в набор.

Для создания правила с помощью Мастера Direct Membership Rule (Правила прямого членства)

  1. На вкладке Membership Rules (Правила членства) диалогового окна Collection Properties (свойства коллекции) нажмите кнопку панели Create Direct Membership Rule Wizard (Мастер создания правил прямого членства).
  2. В диалоговом окне Create Direct Membership Rule Wizard (Мастер создания правил прямого членства) нажмите кнопку Next (Далее).
  3. В диалоговом окне Search for Resources (Поиск рсурсов) в списке Resource Class (Класс ресурса) выберите System Resource (Ресурс системы). В списке Attribute Name (Имя атрибута) выберите операционную систему и версию. В поле Value (Значение) введите Microsoft Windows %Workstation%. Нажмите Next (Далее).
  4. В диалоговом окне Collection Limiting (ограничения коллекции) нажмите кнопку Browse (Обзор) для вывода списка доступных наборов (коллекций). Выберите нужный набор и нажмите кнопку "ОК".
  5. В диалоговом окне Collection Limiting (Ограничения коллекции) нажмите кнопку Next (Далее).
  6. В диалоговом окне Select Resources (выбор ресурсов) выводится список всех ресурсов, соответствующих критериям набора. Нажмите кнопку Select All (Выбрать все) для включения в набор всех ресурсов или выделите нужные ресурсы. В набор будут добавлены ресурсы, соответствующие его критериям. Нажмите Next (Далее).
  7. В диалоговом окне Completing the Create Direct Membership Rule Wizard (Мастер завершения создания правил прямого членства) нажмите кнопку Finish (Готово).

    Созданное правило добавляется в список правил в диалоговом окне Collection Properties (Свойства коллекци).

Теперь нужно задать время начала действия набора.

Для задания времени начала действия коллекции (набора)

  1. На вкладке Membership Rules (Правила членства) в диалоговом окне Collection Properties (Свойства коллекции) выберите Schedule (Расписание).
  2. В диалоговом окне Schedule (Расписание) установите время начала действия набора правил и выберите подходящий шаблон повторения. Нажмите "ОК".
  3. В диалоговом окне Collection Properties (Свойства коллекции) нажмите кнопку Apply (Применить) для применения настроек. Нажмите "ОК".
  4. В окне консоли SMS выберите в области структуры папку Collections (Коллекции).

    Созданный набор правил появляется в панели Name (Имя).


Настройка исходной папки с помощью Мастера развертывания [Руководство сетевого администратора AutoCAD: ]

Создание правила с помощью Мастера Direct Membership Rule (Правила прямого членства)
Использование Microsoft Systems Management Server для установки развертывания
Создание SMS-пакета установки программного обеспечения
Настройка исходной папки с помощью Мастера развертывания

При использовании SMS для развертывания продуктов Autodesk нужно настроить исходную папку с помощью Мастера развертывания. Использование Мастера развертывания является самым легким способом создания исходной папки; он также обеспечивает возможность обновления пакета установки в будущем. Мастер развертывания создает главный установочный образ, который используется SMS для развертывания программного обеспечения Autodesk на клиентских компьютерах. Кроме того, он создает файл преобразования, также известный как файл развертывания, которые необходимо использовать при установке AutoCAD® и программ на основе AutoCAD на клиент-компьютерах.

В SMS местоположение выполнения административной установки становится местоположением исходной папки комплекта. При использовании Мастера развертывания для создания исходной папки можно включать в нее дополнительные файлы, такие как файлы шаблонов, LISP-процедуры и пользовательские меню. Мастер развертывания записывает на диск исполняемый файл Deploy.exe, который используется для развертывания программного обеспечения.

Подробнее о настройке исходной папки для программного обеспечения Autodesk см. Использование Мастера развертывания.

Настоятельно рекомендуется протестировать пакет развертывания, созданный Мастером развертывания, прежде чем начать настройку SMS для развертывания программы. Процедуру тестирования нужно выполнить для того, чтобы быть уверенным, что при работе с главным установочным образом и развертыванием не возникнет никаких затруднений.

Для тестирования пакета развертывания, созданного Мастером развертывания

  1. Выполните вход в систему Windows 2000 или Windows XP Professional под именем пользователя, обладающего правами администратора.
  2. Войдите в исходную папку, в которой было создано развертывание. Используйте Проводник Windows или меню "Пуск" [image] "Выполнить".
  3. Дважды нажмите кнопку мыши на ярлыке, созданном Мастером развертывания.

    Программа будет установлена. Если что-либо препятствует установке, в файл сетевого журнала будет добавлена запись об ошибке.


Создание SMS-пакета установки программного обеспечения [Руководство сетевого администратора AutoCAD: ]

Настройка исходной папки с помощью Мастера развертывания
Использование Microsoft Systems Management Server для установки развертывания
Создание SMS-программы
Создание SMS-пакета установки программного обеспечения

После создания исходной папки с помощью Мастера развертывания нужно создать SMS-пакет установки программного обеспечения. SMS-пакет содержит набор файлов и инструкций, которые SMS использует для развертывания программы на клиент-компьютерах. Набор файлов и инструкций создается Мастером развертывания, но SMS необходимо настроить для использования этих файлов.

Для создания SMS-пакета установки программного обеспечения

  1. В меню "Пуск" (Windows) выберите "Все программы" (или "Программы") [image] System Management Server [image] "Консоль администратора SMS".
  2. В окне консоли SMS выберите в области структуры папку Systems Management Server и нажмите значок "плюс" (+) слева от папки Site Database .
  3. В области структуры выберите папку Packages (Комплекты).

    В области Name (Имя) отображается список всех заданных в настоящее время пакетов установки.

  4. Нажмите правой кнопкой мыши на папке Packages (Пакеты). В контекстном меню выберите "Создать" [image] "Пакет".
    ЗамечаниеПункт контекстного меню Package from Definition (Пакет по определению) недоступен, так как программа не создает файл определения пакета (PDF- или SMS-файлы).
  5. На вкладке General (Общие) диалогового окна Package Properties (Свойства пакета) введите следующие сведения:
    • В поле Name (Имя) введите имя SMS-пакета, например AutoCAD.
    • В поле "Версия" введите номер версии устанавливаемой программы, например 2007.
    • В поле Publisher (Автор публикации) введите Autodesk, Inc.
    • В поле Language (Язык) введите язык устанавливаемого продукта, например Русский
    • В поле Comment (Комментарии) введите необходимые комментарии.
  6. Перейдите на вкладку Data Source (Источник данных).
  7. На вкладке Data Source (Источник данных) выберите опцию This Package Contains Source Files (Этот пакет содержит файлы источника). Нажмите кнопку Set (Установка).
  8. В диалоговом окне Set Source Directory (Установка исходной папки) выберите опцию Network Path (UNC Name) (Путь в сети).
  9. Нажмите кнопку Browse (Обзор). Перейдите в исходную папку, созданную Мастером развертывания. Нажмите "ОК".

    В исходной папке появятся выбранные имя сервера и общей папки.

    ЗамечаниеСозданный Мастером развертывания главный установочный образ также должен появиться в исходной папке.
  10. В диалоговом окне Set Source Directory (Установка исходной папки) нажмите кнопку "ОК".
  11. В диалоговом окне Package Properties (Свойства пакета) нажмите кнопку "ОК".
  12. В области структуры выберите папку Packages (Пакеты).

    В области Name (Имя) отображается созданный пакет.

Несмотря на то, что установочный пакет программы был создан на клиент-компьютерах SMS, установить продукт все еще невозможно. Сначала нужно создать SMS-программу для пакета.


Создание SMS-программы [Руководство сетевого администратора AutoCAD: ]

Создание SMS-пакета установки программного обеспечения
Использование Microsoft Systems Management Server для установки развертывания
Использование исполняемого файла развертывания для создания программы
Создание SMS-программы

Данный раздел предоставляет сведения о параметрах настройки, необходимых для создания SMS-программы для приложений Autodesk. Параметры настройки программы для развертывания приложений в сети задаются в SMS в диалоговом окне Program Properties (Свойства программы).

Существуют два способа задания параметров настройки программы для приложений Autodesk. В первом случае используется исполняемый файл развертывания, созданный Мастером развертывания для AutoCAD и других продуктов семейства AutoCAD. Во втором случае используется установщик программ Windows.

Темы в этом разделе

  • Использование исполняемого файла развертывания для создания программы
  • Использование установщика программ Windows для создания программы


Использование исполняемого файла развертывания для создания программы [Руководство сетевого администратора AutoCAD: ]

Создание SMS-программы
Создание SMS-программы
Использование установщика программ Windows для создания программы
Использование исполняемого файла развертывания для создания программы

Мастер развертывания формирует главный установочный образ и исходную папку для развертывания программных продуктов Autodesk, а также создает в папке AdminImage, вложенной в заданную в Мастере общую сетевую папку, исполняемый файл Deploy.exe.

Deploy.exe является оболочкой установщика программ Windows (т.е. исполняемым файлом, выполняющим необходимую проверку перед запуском установщика). Кроме того, он осуществляет некоторые другие важные проверки и операции, необходимые для установки AutoCAD и других продуктов семейства AutoCAD. Deploy.exe выполняет проверку операционной системы на соответствие минимальным требованиям для установки AutoCAD. Deploy.exe проверяет версию Windows Installer 3.1. Если установлена другая версия, на клиентский компьютер устанавливается Windows Installer 3.1. Deploy.exe также отвечает за запись всех успешно завершившихся и невыполненных установок в файл сетевого журнала, заданный в Мастере развертывания. Для развертывания AutoCAD и других продуктов семейства AutoCAD на клиентских компьютерах SMS настоятельно рекомендуется использовать именно этот способ.

ЗамечаниеНадстройка Macromedia Flash Player 8 (устанавливается с AutoCAD 2007) может привести к сбою SMS 2003.

Для создания программы с помощью файла Deploy.exe

  1. В меню "Пуск" (Windows) выберите ""Программы" [image] System Management Server [image] "Консоль администратора SMS".
  2. В окне консоли SMS выберите в области структуры папку Systems Management Server (Сервер управления системами) и нажмите значок "плюс" (+) слева от папки Site Database .
  3. В области структуры нажмите значок "плюс" (+) слева от папки Packages для раскрытия вложенного списка. В области структуры отображаются имеющиеся пакеты. Нужно выбрать пакет, созданный ранее для данной установки. В области Name (Имя) отображаются папки Access Accounts, Distribution Points и Programs.
  4. В области Name нажмите правой кнопкой мыши на папке Programs (Программы). В контекстном меню выберите New (Создать) [image] Program (Программа).
  5. На вкладке General (Общие) диалогового окна Program Properties (Свойства программы) введите следующие сведения:
    • В поле Name (Имя) введите имя программы. Имя должно быть уникальным, так как оно будет использоваться для анонсирования. На компьютерах-клиентах заданное имя отображается на Панели управления Windows в папке Advertised Programs (Анонсируемые программы).
    • В поле Comment (Коментарии) введите необходимые комментарии. Текст, введенный в поле Comment, на клиент-компьютерах отображается в диалоговом окне Advertised Programs Monitor или в Advertised Programs wizard (Мастер анонсируемых программ) Панели управления.
    • В командной строке нажмите кнопку Browse (Обзор). Войдите в исходную папку, в которой Мастером развертывания был создан пакет развертывания. Нажмите правую кнопку мыши на ярлыке развертывания и выберите пункт Properties (Свойства). На вкладке Shortcut (Ярлык) выделите весь текст в поле Target (Цель). Нажмите правую кнопку мыши и выберите Copy (Копировать). Для закрытия диалогового окна Deployment Properties (Свойства развертки) нажмите кнопку Cancel (Отмена). Для закрытия диалогового окна Open (Открыть) нажмите кнопку Cancel (Отмена). В диалоговом окне Program Properties (Свойства программы) в командной строке нажмите правую кнопку мыши и выберите команду Paste (Вставить). Отображается вставленный текст.
    • В списке Run (Выполнить) выберите Normal (Обычный).
    • В списке After Running (После выполнения) выберите No Action Required.
  6. Перейдите на вкладку Requirements (Требования). В поле Estimated Disk Space (Предполагаемое дисковое пространство) укажите не менее 750 Мбайт. Выберите опцию This Program Can Run Only on Specified Platforms (Данная программа может быть выполнена только на определенных платформах). Выберите из списка следующие платформы:
    • Все клиенты x86 Windows 2000
    • Все клиенты x86 Windows XP Professional
    • Клиенты x86 оригинальной версии Windows 2000
    • Клиент-компьютеры x86 с системой Windows 2000 с пакетом обновления 1
    • Клиент-компьютеры x86 с системой Windows 2000 с пакетом обновления 2
  7. Перейдите на вкладку Environment (Окружение). В списке Program Can Run (Программы для выполнения) выберите Only When a User Is Logged On (Только при входе пользователя в систему) (в SMS 2.0 установите флажок User Input Required (Требуется ввод пользователя)). В группе Run Mode (Режим выполнения) выберите опцию Run with Administrative Rights (Выполнения с административными правами), если пользователи не имеют прав администратора компьютера. В группе Drive Mode (Режим запуска) выберите Runs with UNC Name.
  8. Нажмите кнопку Apply (Применить), а затем "ОК". В окне консоли SMS в области структуры раскройте папку Programs (Программы), чтобы убедиться в присутствии новой программы в области Name (Имя).


Использование установщика программ Windows для создания программы [Руководство сетевого администратора AutoCAD: ]

Использование исполняемого файла развертывания для создания программы
Создание SMS-программы
Создание анонсирования
Использование установщика программ Windows для создания программы

При использовании установщика программ Windows для настройки основных параметров программы для приложений Autodesk нужно определить синтаксис, который будет использоваться в командной строке. Интерпретацией пакетов и установкой продуктов занимается программа Msiexec.exe. При использовании установщика программ Windows записи в файл сетевого журнала не вносятся.

ЗамечаниеПеред развертыванием программ Autodesk на клиент-компьютерах необходимо проверить версию Windows Installer program (Msiexec.exe): должна быть 3.1 или выше. Программа установки Windows Installer 3.1 находится на устаночном диске с программой Autodesk.

В диалоговом окне "Свойства" установщика программ Windows на вкладке "Общие" необходимо ввести в командной строке следующее:

msiexec options < комплект> .msi

Для AutoCAD вместо <пакет> нужно подставить acad.msi. В приведенной ниже таблице перечислены параметры командной строки, необходимые для развертывания пакета AutoCAD (acad.msi). Параметры командной строки необходимо вводить с учетом регистра. Полный список параметров с пояснениями можно найти в Справочной системе установщика программ Windows.

Параметры командной строки для установщика программ Windows
Параметр | Действие
/I | Установка/настройка продукта.
/x | Удаление продукта из системы.
/lev Файл_журнала | Задание пути к файлу журнала. Информация для включения в файл журнала задается с помощью флагов. e - сообщения обо всех ошибках; v - вывод расширенных сообщений
/qb- | Задание варианта пользовательского интерфейса.
 | qb - Basic UI

Например, для AutoCAD нужно использовать следующий синтаксис: msiexec /I acad.msi

Кроме параметров командной строки требуется задать свойства установщика программ Windows. Свойствами называются глобальные переменные, используемые для установки. Чтобы воспользоваться преимуществами файла преобразования, созданного Мастером развертывания, потребуется воспользоваться свойством TRANSFORMS. Свойства следует задавать следующим образом:

msiexec options <пакет>.msi СВОЙСТВО=ЗНАЧЕНИЕ

Некоторые свойства командной строки перечислены в приведенной ниже таблице. Параметры командной строки необходимо вводить с учетом регистра. Полный список свойств с пояснениями можно найти в Справочной системе установщика программ Windows.

Свойства командной строки для установщика программ Windows
Свойство | Действие
TRANSFORMS= | Список преобразований для применения к базе данных установки (acad.msi).
ACAD_SILENT_LICENSE=YES | Недиалоговый режим установки.
INSTALLDIR= |

Для AutoCAD нужно использовать следующий синтаксис параметров и свойств командной строки:

msiexec /I <путь>\acad.msi TRANSFORMS=<путь>\<имя преобразования>.mst /qb-

Для использования Msiexec.exe для развертывания пакетов AutoCAD

  1. В меню "Пуск" (Windows) выберите "Все программы" (или "Программы") [image] System Management Server [image] "Консоль администратора SMS".
  2. В окне консоли SMS следует выбрать в области структуры папку Systems Management Server(Сервер управления системами) и нажать значок "плюс" (+) слева от папки Site Database(База данных узла).
  3. В области структуры нажмите на значке "плюс" (+) слева от папки Packages (Пакеты) для раскрытия вложенного списка. В области структуры отображаются имеющиеся пакеты. Нужно выбрать пакет, созданный ранее для данной установки. В области Name (Имя) отображаются папки Access Accounts,, Distribution Points и Programs.
  4. В области Name (Имя) нажмите правую кнопку мыши на папке Programs (Программы). В контекстном меню выберите New (Создать) [image] Program (Программа).
  5. На вкладке General (Общие) диалогового окна Program Properties (Свойства программы) введите следующие сведения:
    • В поле Name (Имя) введите имя программы. Имя должно быть уникальным, так как оно будет использоваться для анонсирования. На клиент-компьютерах заданное имя отображается на Панели управления Windows в папке Advertised Programs (Анонсируемые программы).
    • В поле Comment (Комментарии) введите необходимые комментарии. Текст, введенный в поле Comment, на клиентских компьютерах отображается в диалоговом окне Advertised Programs Monitor (Монитор анонсируемых программ) или в Advertised Programs wizard (Мастере анонсируемых программ) Панели управления.
    • В командной строке введите команду, пользуясь синтаксисом командной строки установщика программ Windows. Для AutoCAD нужно использовать следующий синтаксис:

    Msiexec /I <путь>\acad.msi TRANSFORMS=<путь>\<имя развертывания>.mst/qb-

    В качестве<пути> следует указать исходную папку или путь к главному установочному образу, созданному Мастером развертывания. Путь должен вводиться в соответствии с соглашением об универсальном именовании (UNC). Вместо параметра <имя развертывания> следует указать имя развертывания, созданного Мастером развертывания. Используйте расширение файлаmst.

  6. Перейдите на вкладку Requirements (Требования). В поле Estimated Disk Space (Предполагаемое дисковое пространство) укажите не менее 750 Мбайт. Выберите параметр This Program Can Run Only on Specified Platforms (Данная программа выполняется только на определенных платформах). Выберите следующие платформы в списке:
    • Все клиенты x86 Windows 2000
    • Все клиенты x86 Windows XP Professional
    • Клиенты x86 оригинальной версии Windows 2000
    • Клиент-компьютеры x86 с системой Windows 2000 с пакетом обновления 1
    • Клиент-компьютеры x86 с системой Windows 2000 с пакетом обновления 2
  7. Перейдите на вкладку Environment (Окружение). В списке Рrogram Can Run (Программы для выполнения) выберите Only When a User Is Logged On (Только при входе пользователя в систему). В группе Run Mode (Режим выполнения) выберите опцию Run with Administrative Rights (Выполнение только с административными правами), если пользователи не имеют прав администратора компьютера. В группе Drive Mode (Режим запуска) выберите Runs with UNC Name.
  8. Нажмите кнопку Apply (Применить), а затем Close (Закрыть). В окне консоли SMS в области структуры раскройте папку Programs (Программы), чтобы убедиться в присутствии новой программы в области Name (Имя).

На этом процесс создания программы установки пакетов завершен. Теперь нужно подготовить анонсирование пакета.


Создание анонсирования [Руководство сетевого администратора AutoCAD: ]

Использование установщика программ Windows для создания программы
Использование Microsoft Systems Management Server для установки развертывания
Установка продуктов Autodesk на клиент-компьютере
Создание анонсирования

SMS использует технологию анонсирования для распространения SMS-программ на клиентские компьютеры SMS. Создавать и управлять процессом анонсирования можно в окне консоли администратора SMS.

Для анонсирования пакета

  1. В меню "Пуск" (Windows) выберите "Все программы" (или "Программы") [image] System Management Server [image] "Консоль администратора SMS".
  2. В окне консоли SMS выберите в области структуры папку Systems Management Server (Сервер управления системами) и нажмите значок "плюс" (+) слева от папки Site Database (Узел базы данных).
  3. В области структуры выберите папку Advertisements (Уведомления).

    Список анонсированных программ выводится в области Name.

  4. В области структуры нажмите правую кнопку мыши на папке Advertisements (Уведомления) и выберите All Tasks (Все задачи) [image] Distribute Software (Распространение программного обеспечения).
  5. На первой странице Distribute Software Wizard (Мастера распространения программного обеспечения) нажмите "Далее".
  6. На странице Package (Пакет) установите флажок Distribute an Existing Package (Распространять сущесвующий пакет) (в SMS 2003 установите флажок Existing Package (Существующий комплект)), затем в списке Packages выберите AutoCAD. Нажмите Next (Далее).
  7. На странице Distribution Points (Точки распространения) в группе Distribution Points выберите сервер(ы), откуда будет производиться распространение пакета. Нажмите кнопку Next (Далее).
  8. На странице Advertise a Program (Анонсирование программы) для ответа на вопрос об анонсировании программы для коллекции выберите утвердительный ответ. Убедитесь, что созданная ранее программа присутствует в списке программ. Нажмите Next (Далее).
  9. На странице Select Program to Advertise (Выбор программ для анонсирования) в области Programs (Программы) выберите программу и нажмите кнопку Next (Далее).
  10. На странице Advertisement Target (Цель уведомления) выберите Advertise the Program to an Existing Collection (Анонсирование программы для существующей коллекции) и нажмите кнопку Browse (Обзор). В диалоговом окне Browse Collection (Обзор коллекции) выберите созданную ранее коллекцию и нажмите кнопку "ОК". На странице Advertisement Target (Цель уведомления) нажмите Next (Далее).
  11. На странице Advertisement Name (Имя уведомления) в поле Name (Имя) введите имя для анонсирования. В поле Comment (Комментарии) введите необходимые комментарии. Введенное имя и комментарии отображаются на клиент-компьютере. Нажмите Next (Далее).
  12. На странице Advertise to Subcollections (Анонсирование для субколлекции) можно указать, следует ли применять анонсирование и для вложенных коллекций. Выберите подходящий вариант и нажмите Next (Далее).
  13. На странице Advertisement Schedule (Расписание анонса) выберите Yes (Да) для того, чтобы анонсирование было ограничено по сроку действия, или No (Нет) для выбора анонсирования с неограниченным сроком действия. Если на предыдущем шаге было выбрано анонсирование с ограниченным сроком действия, задайте дату и время окончания срока его действия. Нажмите Next (Далее).
  14. На странице Assign Program (Назначенная программа) выберите Yes (Да), если нужно назначить программу. В противном случае выбрать No (Нет). Назначенная программа запустится автоматически, если она еще не была запущена на клиенте SMS. Если было выбрано "Да", нужно ввести дату и время, на которые назначена программа. Нажмите "Далее".
  15. На странице Completing the Distribute Software Wizard (Мастера распространения программного обеспечения) нажмите кнопку Finish (Готово). В окне консоли SMS в области структуры раскройте папку Advertisements (Уведомления), чтобы убедиться в присутствии новой программы в области Name (Имя).

Теперь можно установить программное обеспечение Autodesk на клиент-компьютере SMS.


Установка продуктов Autodesk на клиент-компьютере [Руководство сетевого администратора AutoCAD: ]

Создание анонсирования
Использование Microsoft Systems Management Server для установки развертывания
Распространения программы с использованием программы создания образов
Установка продуктов Autodesk на клиент-компьютере

Для установки программ Autodesk нужно выполнить вход в систему компьютера, на котором установлена программа-клиент SMS. Компьютер должен иметь членство в домене, обслуживаемом SMS-сервером. Если при создании программы не была выбрана опция запуска с правами администратора (Run with administrative rights), нужно выполнить вход в систему с учетной записи администратора.

Проверить установку на компьютере SMS-клиента можно с помощью трех элементов Панели управления: Systems Management (Управление системами), Advertised Programs (Анонсируемые программы) и Advertised Programs Monitor (Монитор анонсируемых программ).

ЗамечаниеВ Windows XP эти элементы видны только в случае, когда для просмотра элементов Панели управления выбран классический вид.

Чтобы установить программу на клиентский компьютер SMS

  1. Из меню "Пуск" (Windows) выберите "Панель управления".
  2. В Панели управления дважды нажмите кнопку мыши на Advertised Programs (Анонсируемые программы).

    Запускается Advertised Programs wizard (Мастер анонсирования).

  3. На странице Welcome to the Advertised Programs Wizard Добро пожаловать в мастер...) нажмите кнопку Next (Далее).
  4. На странице Select Programs to Run (Выбор программ для выполнения) в группе Advertised Programs (Анонсируемые программы) выберите анонсируемую программу Autodesk и нажмите Next (Далее).
  5. На странице Run Programs Now or Later (Выполнить программы раньше или позже) выберите опцию Run the Selected Program Now (Выполнить выбранную программу сейчас) для немедленного запуска выбранной программы и нажмите Next (Далее).
  6. На странице Completing the Advertised Programs Wizard (Мастер завершения анонсированных программ) нажмите кнопку Finish (Готово).

Процесс установки программы Autodesk с помощью SMS завершен. Для знакомства с другими способами установки программ Autodesk с помощью SMS и дополнительными возможностями этой системы следует изучить документацию по SMS.


Распространения программы с использованием программы создания образов [Руководство сетевого администратора AutoCAD: ]

Установка продуктов Autodesk на клиент-компьютере
Распространение развертывания отдельной версии программы Autodesk на несколько рабочих мест с помощью главного образа
Распространения программы с использованием программы создания образов

Следующая информация предназначены для тех, кто для распространения программ Autodesk использует главный образ. Autodesk не рекомендует и не поддерживает такой метод развертывания, так как лицензирование программы может конфликтовать со средами. Если для распространения программ Autodesk с узлового компьютера на все рабочие используется программа для создания образов, возникает риск неполной установки и возможные проблемы с активацией.

ЗамечаниеЕсли в компьютере используется RAID массив (или аналогичная среда), распространять программы Autodesk с помощью программы создания образов невозможно.

Темы в этом разделе

  • Распространение развертывания отдельной версии программы Autodesk на несколько рабочих мест с помощью главного образа
  • Восстановление главного образа
  • Распространение сетевого развертывания программы Autodesk на несколько рабочих мест с помощью главного образа


Распространение развертывания отдельной версии программы Autodesk на несколько рабочих мест с помощью главного образа [Руководство сетевого администратора AutoCAD: ]

Распространения программы с использованием программы создания образов
Распространения программы с использованием программы создания образов
Восстановление главного образа
Распространение развертывания отдельной версии программы Autodesk на несколько рабочих мест с помощью главного образа

Отдельную версию программы для нескольких рабочих мест можно распространять с помощью главного образа.

Если программа Autodesk уже запускалась на основном компьютере, то этот компьютер следует тщательно очистить.

Чистка основного компьютера и восстановление операционной системы

  1. Удалите все с жесткого диска, включая загрузочный сектор.

    Например, для утилиты Norton’s GDISK используется следующая команда:

    gdisk 1 /diskwipe

    ЗамечаниеЕсли используется другая программа, необходимо убедиться, что очищается загрузочный сектор. В противном случае будет невозможно активировать программы Autodesk.
  2. Создайте новый раздел, с резервного или установочного диска установите операционную систему.

Распространение отдельной версии программы Autodesk на несколько рабочих мест с помощью главного образа

  1. Создайте сетевое развертывание для отдельной версии программы на несколько рабочих мест. Подробнее см. в Использование Мастера развертывания.
  2. Установите путем развертывания программу Autodesk на основной компьютер.
  3. На основном компьютере выполните одно из следующих действий:
    • Создайте главный образ, включая загрузочный сектор. Протестируйте программу на другом компьютере перед ее распространением. Запустите программу на другом компьютере, зарегистрируйте и активируйте ее. Для регистрации и активации программы на компьютерах пользователя отводится 30-дневный период.
    • Запустите и настройте программу (если требуется). Создайте главный образ и распространите его среди пользователей. Если компьютеры пользователей подключены к сети Интернет, производится автоматическая активация программного продукта. Пользователи, чьи компьютеры не подключены к сети Интернет, должны выполнить регистрацию и активацию продукта в течение 7 дней.
  4. Примените главный образ к компьютеру-приемнику.


Восстановление главного образа [Руководство сетевого администратора AutoCAD: ]

Распространение развертывания отдельной версии программы Autodesk на несколько рабочих мест с помощью главного образа
Распространения программы с использованием программы создания образов
Распространение сетевого развертывания программы Autodesk на несколько рабочих мест с помощью главного образа
Восстановление главного образа

В следующей процедуре предполагается, что перед форматированием диска рабочей станции имеется сохраненная копия папки Software Licenses (и папкиProduct Licenses) для всех рабочих станций на другой рабочей станции или на диске DVD.

Восстановление программы с помощью главного образа

  1. Закройте приложение. Не запускайте его до полного завершения данной процедуры.
  2. В проводнике Windows скопируйте из указанной ниже папки папку Software Licenses (и папку Product Licenses, если образ содержит программы Autodesk более старые, чем AutoCAD 2005) в местоположение, находящееся не на том диске, который требуется восстановить.

    C:\Documents and Settings\All Users\Application Data\Autodesk\Software Licenses

    C:\Documents and Settings\All Users\Application Data\Macrovision\Safecast\Product Licenses

  3. Отформатируйте диски рабочей станции и восстановите систему с главного образа.
    ЗамечаниеНе следует выполнять низкоуровневое форматирование жесткого диска.
  4. Скопируйте папку Software Licenses (и/или папку Product Licenses), созданную на шаге 2, в исходное местоположение на рабочей станции.
ЗамечаниеПри восстановлении образа диска все измененные файлы помещаются обратно в своем исходном состоянии. Файлы лицензий сохраняются, повторная активация программ не требуется.


Распространение сетевого развертывания программы Autodesk на несколько рабочих мест с помощью главного образа [Руководство сетевого администратора AutoCAD: ]

Восстановление главного образа
Распространения программы с использованием программы создания образов
Словарь терминов
Распространение сетевого развертывания программы Autodesk на несколько рабочих мест с помощью главного образа

Сетевую лицензированную версию программы можно распространять с помощью главного образа.

Распространение сетевого развертывания программы Autodesk на несколько рабочих мест с помощью главного образа

  1. Создайте сетевое развертывания для сетевой лицензионной программы. Подробнее см. в Использование Мастера развертывания.
  2. Установите путем развертывания программу Autodesk на основной компьютер.
  3. С помощью программы создания образа, например Norton Ghost, создайте главный образ жесткого диска основного компьютера.
  4. Примените главный образ к компьютеру-приемнику.
    ЗамечаниеСервер лицензий должен быть запущен, и все компьютеры должны быть подключены к сети для получения лицензии на программу.


Словарь терминов [Руководство сетевого администратора AutoCAD: ]

Распространение сетевого развертывания программы Autodesk на несколько рабочих мест с помощью главного образа
Словарь терминов
Active Directory

Служба каталогов компании Microsoft, которая используется в операционных системах Windows 2000 и Windows 2003 Server.

FLEXlm

Технология управления лицензиями компании Macrovision Software, Inc. FLEXlm предоставляет средства администрирования, которые позволяют упростить управление сетевыми лицензиями. Средства FLEXlm можно использовать для просмотра статуса сетевых лицензий, восстановления лицензий, потерянных вследствие сбоев системы, устранения ошибок на серверах лицензий, а также обновления существующих файлов лицензий.

MSI

Установщик программ Microsoft installer. Поддерживает большой набор параметров, которые можно использовать в сценариях установки.

MSP

Файл обновлений, разработанный Microsoft (см. также обновление)

MST

Файл преобразования. Производит настройку компонентов, установленных MSI-файлом. Например, мастер развертывания создает MST-файл с заданными настройками. Созданное мастером развертывание использует MST-файл совместно с файлами MSI и MSIEXEC для установки программы на локальные рабочие станции.

SMS

Systems Management Server (Система управления сетями). Средство администрирования сетевых компьютеров с помощью удаленной настройки, принудительного развертывания и администрирования пользователей. SMS является довольно дорогой технологией, которую нужно приобретать отдельно как дополнительный сервер.

автономная установка на несколько пользователей

Тип установки, в котором устанавливаются автономные версии программ для нескольких пользователей с использованием одного серийного номера.

активация (activate)

Этап процесса регистрации программ Autodesk, позволяющий запускать программу в соответствии с лицензионным договором.

анонсирование (advertising)

Технология передачи данных по требованию, которая позволяет уведомлять пользователей о доступных для установки обновлениях программных продуктов. Для завершения установки анонсируемого продукта пользователь должен дважды нажать кнопку мыши на ярлыке программы (или выполнить аналогичную операцию, открывающую приложение).

Быстрый запук AutoCAD (acstart17.exe)

Оперативная процедура, которая позволяет ускорить первоначальный запуск AutoCAD.

главный установочный образ (administrative image)

Набор доступных для пользователей сети файлов, созданный Мастером развертывания и используемый для установки программы на рабочие станции. С помощью Мастера развертывания в главный установочный образ могут включаться пакеты обновлений и отдельные обновления.

групповая политика (group policy)

Серверная технология Microsoft, служащая для выполнения принудительных установок и установок на основе анонсирования при помощи стандартных компонентов администрирования Microsoft 2000 Server.

обновление (patch)

Программное обновление для приложения.

опытный пользователь (power user)

Пользователь, обладающий правами на доступ и запись в папку Program Files и раздел реестра HKEY_Local_Machine.

пакет обновления (service pack)

Термин, использующийся для обозначения файлов обновления продуктов Autodesk.

преобразование (transform)

См. MST.

процесс развертывания (deploy)

Процесс установки продуктов Autodesk на один или несколько компьютеров в сети.

работа со сценариями (scripting)

Процедура использования языков сценариев, например VB Script, для облегчения развертывания пакетов программного обеспечения.

развертывание (deployment)

Ссылка на уникальный MST-файл, служащий основой для установки. С помощью Мастера развертывания администратор может создать несколько развертываний, предназначенных для разных типов установки для пользователей.

служба каталогов (directory service)

Сетевая служба, которая хранит сведения о ресурсах сети и предоставляет возможность пользователям и приложениям легко находить и использовать эти данные. К ресурсам сети в данном случае относятся адреса электронной почты, учетные записи компьютеров и периферийные устройства, такие как принтеры. В идеале, служба каталога должна делать топологию физической сети и используемые протоколы настолько прозрачными, чтобы пользователи могли получить доступ к любому сетевому ресурсу вне зависимости от того, где он физически расположен. Все службы каталогов основаны на стандарте X.500 ITU.

технология передачи данных по требованию (pull technology)

Технология установки, требующая от пользователя определенных действий для завершения процесса установки.

технология принудительной передачи данных (push technology)

Технология установки, не требующая участия пользователя в установке файлов на рабочий стол удаленной рабочей станции.

установка в недиалоговом режиме (silent installation)

Режим установки, не требующий от пользователя ввода информации. Во время процесса установки диалоговые окна не выводятся.

установочный образ (installation image)

Развертывание, состоящее из файла MSI, всех связанных преобразований, выбранных пользователем дополнительных нестандартных файлов, профиля и параметров реестра.

частичный профиль (partial profile)

Профиль, содержащий значения некоторых параметров реестра, которые заданы в соответствии с набором опций, доступных на вкладке "Файлы" диалогового окна "Настройка".


Комментарии пользователя

Данная форма предназначена для ввода замечаний и предложений, которые будут отправлены в группу технической документации компании Autodesk.

Заголовок и расположение раздела (не изменять):
Имя и фамилия (не обязательно):
         E-mail (не обязательно):
Текст комментария:

Замечание: Форма не может служить средством получения советов или технической поддержки. Информация из нее будет использована для улучшения документации по продукту. Благодарим Вас!